Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Ubuntu 8.04, Pulse Audio... HowTo

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
subulu






Anmeldungsdatum: 02.08.2008
Beiträge: 10
Wohnort: Zalaegerszeg Ungarn


blank.gif

BeitragVerfasst am: 04.08.2008, 10:15    Ubuntu 8.04, Pulse Audio... HowTo Antworten mit ZitatNach oben

Die Probleme liegen einerseits bei pulseaudio, das noch ziemlich frisch daher kommt und mit dem viele Anwendungen Schwierigkeiten haben und dann im Zusammenspiel zwischen Audacity und Jackd, wo es auf genaue Abstimmung ankommt.
Erst mal ist es nötig ein paar Anpassungen im System vorzunehmen, damit audio generell unter 8.04 gut funktioniert und auch Anwendungen wie skxpe, flash oder twinkle astrein funktionieren. Dann hat der Kernel eine Stromsparfunktion, die wenig bringt, aber vor allem dem Sound zusetzt. Also abschalten bringt (nicht nur bei mir) deutliche Verbesserungen was die Soundqualität bei Aufnahmen angeht.
Dann als drittes scheint es so zu sein, dass Audacity automatisch Jackd beim Aufrufen startet, also nicht vorher gestartet werden darf. Dann kommt es darauf an, dass die Einstellungen der beiden Programme zueinander passen, sonst gibts Probleme beim erkennen oder das System hängt sich auf.
Viertens, weil Audacity nicht mit pulseaudio zusammenarbeitet, sondern sie sich ausschließen (entweder/oder), sollte audacity mit einem Befehl gestartet werden, der pulseaudio für die Dauer der Arbeit mit audacity pausiert.
Aber von Anfang an:

1. Allgemeiner Sound und Zusammenarbeit von pulseaudio mit anderen Programmen

Anleitung Punkt für Punkt abarbeiten. Ist sehr gut und einfach gehalten und lässt sich leicht umsetzen, wenn man weiß was ein Terminal ist wink Einfach copy und paste und die Einstellungen für skype (steht dort) und twinkle usw., so man hat, anpassen (twinkle Audio in den Einstellungen auf oss setzen). Skype und twinkle geben zwar keine berauschende Qualität, zumindest bei mir nicht, aber es funktioniert und was mich interessiert, ist die Musikaufnahme und Bearbeitung.

2. Stromsparfunktion abstellen
nohz= off
stellen. Geht so:

sudo nano /boot/grub/menu.lst

in den Terminal eingeben
Kennwort, dann nach aktuellstem Kerneleintrag suchen (wird bei Dir ein anderer sein) und in die "Kernel"-Zeile nohz=off am Ende eintragen. Sieht dann so aus:

title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd0,1)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=d01c8f74-2cb0-4f2e-940e-8428084b03f3 ro quiet splash nohz=off
initrd /boot/initrd.img-2.6.24-16-generic
quiet

Mit Strg O speichern und mit Strg X schließen. Damit ist die soundstörende Stromsparfunktion abeschaltet. Das Problem und die Lösung sind übrigens schon seit 2004 in den Foren zu finden.

3. Programme installieren
Jackd, qjackctl und audacity installieren (über synaptic).

4.Jack konfigurieren
Dann als erstes über Anwendungen/Unterhaltungsmedien Jackcontrol starten und auf start drücken. Gibt es XRuns? Das sind die roten Zahlen links im Fenster. Wenn dort nur eine 1 steht beim Starten des Programms, sind die Einstellungen wahrscheinlich nicht schlecht, muss aber konkret im Zusammenspiel mit einem Programm geprobt werden. Ich hatte lange Probleme, bis ich im setup die Periods/Buffer (frag mich nicht, was das ist wink) von 2 auf 3 gestellt habe. seitdem läuft das ganze rund. Eine ganz gute Anleitung (wenn auch für Jacklab von suse, passt aber auch für Ubuntu) gibt es hier.
Entscheidend für das Zusammenspiel mit Audacity ist die Samplerate (bei Audacity Samplefrequenz genannt) (in meinem Fall ohne Echtzeitkernel 44100). Die müssen bei Jackd und bei Audacity identisch eingestellt sein, sonst geht nichts. Deswegen: aufschreiben und merken! Ebenso schauen, ob "Force 16 Bit" mit einem Häkchen aktiviert ist. Das ist das Sampleformat, wenn nichts aktiviert ist, sind es 32 Bit. Dann Jack stoppen (!) und beenden; erst stoppen, sonst läuft Jack die ganze Zeit im Hintergrund weiter und es gibt wahrscheinlich Probleme beim Start von Audacity.

5. Audacity zur Zusammenarbeit mit Jack bewegen / Konflikt mit pulseaudio beseitigen
Audacity so einstellen, dass pulseaudio pausiert, wenn audacity aingeschaltet wird. Sonst läuft nichts mit aufnehmen und abspielen, zumal dann nicht, wenn irgendeine andere anwendung gerade auf den sound zugreift. Dafür mit der rechten Maustaste im Ubuntudesktop auf Anwendungen klicken und "Menues bearbeiten" auswählen. Unterhaltungsmedien anklicken und wieder mit der rechten Maustaste audacity klicken. Eigenschaften auswählen und unter "Befehl" "pasuspender -- audacity" ohne die Anführungszeichen eingeben und wieder schließen und beenden. Wenn jetzt das Programm gestartet wird, pausiert pulseaudio, und audacity hat freien zugriff auf jackd. Also wenn z.B ein videoplayer läuft oder Rhythmbox oder so, stoppt der solange, wie audacity läuft und macht sofort weiter, sobald audacity geschlossen wird.

6. Audacity konfigurieren

Audacity starten (startet jackd automatisch im Hintergrund mit). Unter Bearbeiten / Einstellungen den Reiter Audio E/A aufrufen und die Geräte für Aufnahme und Wiedergabe auf "Jack Audio Cennection Kit: System" stellen. Unter dem Reiter Qualität schauen, ob die Standard-Samplefrequenz und das Standard-Sampleformat identisch eingestellt sind zu den Einstellungen in Jackd. Bei mir sind das 44100 und 32 bit. 32 bit sind, soweit ich weiß, Standard bei Jackd.
Ok Klicken. Und loslegen.

Viel Spaß, es sollte alles in bestechender Soundqualität funktionieren.


Desktop: Gnome

Version: 8.04
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 04.08.2008, 10:35    (Kein Titel) Antworten mit ZitatNach oben

Hello und Thanks für deine Ausführliche Dokumentation!

Ich habe deine Beitrag in HowTo verschoben... gehört doch eher in diesen Bereich.
Titel etwas geändert....

Marion @Admin


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
subulu






Anmeldungsdatum: 02.08.2008
Beiträge: 10
Wohnort: Zalaegerszeg Ungarn


blank.gif

BeitragVerfasst am: 04.08.2008, 11:20    Prima! Danke ... Antworten mit ZitatNach oben

muss wohl etwas blind gewesen sein auf der Suche nach einer geeigneten Rubrik ... Embarassed

Desktop: Gnome

Version: 8.04
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Blitzkneisser
Gast










BeitragVerfasst am: 31.08.2008, 21:16    Warum geht bei Skype dann nicht das Mikro vom Alsaplayer? Antworten mit ZitatNach oben

Das hat mir noch niemand sagen könne.
Das lustige ist ja ich habe nur Ubuntu drauf am HP Pavillion 6133 Geforce 7200 und bei mir funktioniert es und bei meinen Sohn mit dem HP Pavillion 9000 Serie Geforce 8400 geht es nicht!
Das bedeutet für ihn weil er auch noch Vista drauf hat aber zwei Skype Adressen, er arbeitet stur in Vista weiter!
Leider!
Vielleicht ist es wegen dem Vista und Ubuntu?
Ich habe schon wahrscheinlich alles versucht und keine Lösung erzielen können!
Ciao


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
subulu






Anmeldungsdatum: 02.08.2008
Beiträge: 10
Wohnort: Zalaegerszeg Ungarn


blank.gif

BeitragVerfasst am: 02.09.2008, 12:18    Skype und ubuntu 8.04 Antworten mit ZitatNach oben

Geh mal meine Anleitung Punkt für Punkt durch, da steht auch drin warum skype mit alsa in Ubuntu 8.04 nicht kann, nämlich wegen pulseaudio. Danach sollte es gehen, zwar nicht in gleich bestechender soundqualität wie bei windows aber immerhin. Oder schau hier:

http://nyuviu.wordpress.com/2008/08/03/ubuntu-804-soundprobleme-mit-audacity-pulseaudio-skype-twinkle-jack/


Desktop: Gnome

Version: 8.04
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Blitzkneisser
Gast










BeitragVerfasst am: 02.09.2008, 14:20    Danke Antworten mit ZitatNach oben

Aber das habe ich schon probiert und es geht nicht!

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
subulu






Anmeldungsdatum: 02.08.2008
Beiträge: 10
Wohnort: Zalaegerszeg Ungarn


blank.gif

BeitragVerfasst am: 02.09.2008, 16:48    (Kein Titel) Antworten mit ZitatNach oben

Warst Du auf http://ubuntuforums.org/showthread.php?t=789578 ?
Ich bin nun auch nicht der Crack bei speziellen Problemen, aber versuch docjh auch mal folgende Links:
http://divyad.wordpress.com/2008/05/01/install-skype-on-ubuntu-804-hardy-heron-configure-sound/
http://forum.meinskype.de
http://www.red91.com/2008/05/11/install-skype-ubuntu-8-04
was für ein system es ist, speilt auch eine rolle (siehe links): 386? 686?
Google einfach mal 'skype und ubuntu 8.04' für weitere Ideen, was Lösungen betrifft. An Vista und Ubuntu liegt es mit großer Sicherheit nicht, weil die beiden getrennt voneinander laufen. Ansonsten VMWare oder Virtualbox installieren und Vista mit skype darin laufen lassen


Desktop: Gnome

Version: 8.04
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
subulu






Anmeldungsdatum: 02.08.2008
Beiträge: 10
Wohnort: Zalaegerszeg Ungarn


blank.gif

BeitragVerfasst am: 02.09.2008, 16:52    (Kein Titel) Antworten mit ZitatNach oben

Probier doch mal, wenn nicht schon getan, die ganzen Einstellmöglichkeiten für das Mikro-Audiogerät durch. Bei mir ist es HDA VIA VT82xx.
Lautsprecher und Klingeln auf Pulse setzen.


Desktop: Gnome

Version: 8.04
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Reither





Alter: 40
Anmeldungsdatum: 15.01.2009
Beiträge: 37
Wohnort: Wien


austria.gif

BeitragVerfasst am: 28.01.2009, 23:13    Bei Skype geht das Mikro aber trotzdem nicht! Antworten mit ZitatNach oben

CBACK CrackerTracker Professional

Ansicht der Beiträge des Users durch Admin gesperrt!


Desktop: Gnome

Version: 8.10
OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050156951 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.148s (PHP: 72% - SQL: 28%) | SQL queries: 65 | GZIP enabled | Debug off ]