Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 NWM 0.7.1 mit E169 in Ibex

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 04.06.2009, 10:13    NWM 0.7.1 mit E169 in Ibex Antworten mit ZitatNach oben

Hi Miteinander,

bei mir gibt es anscheinend ein "Update" Problem.

Seit ich den NWM aus den Launchpad-Repos auf meinem Netbook (siehe Signatur) auf 0.7.1 upgedated habe, wird mein E169 "um die Burg" nicht vom NWM erkannt!?

Die Konsole bringt:

ralf@PQMC-Mini:~$ ls -l /dev/ttyU*
crw-rw---- 1 root dialout 188, 0 2009-06-04 10:05 /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 1 2009-06-04 10:05 /dev/ttyUSB1
crw-rw---- 1 root dialout 188, 2 2009-06-04 10:05 /dev/ttyUSB2
ralf@PQMC-Mini:~$ lsusb
Bus 005 Device 002: ID 0b05:b700 ASUSTek Computer, Inc.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 004: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 045e:00e1 Microsoft Corp. Wireless Laser Mouse 6000 Reciever
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 04f2:b071 Chicony Electronics Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


An- & Abstecken des Modems bringt nichts. Ich habe mit Modem gebootet, ohne gebootet, etc. Die Verbindung habe ich neu angelegt. Der NWM bleibt regungslos.

In PCMAnFM werden sowohl das virt. CD-Rom als auch die Speicherkarte die im Stick ist angezeigt und sind mountable.

Hat da jemand Rat?

LG, Ralf


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 04.06.2009, 11:51    (Kein Titel) Antworten mit ZitatNach oben

Hello

Hast du den NWM aus den PPA-Qellen installiert?
Der funktioniert derzeit auch mit 8.04 und den UMTS-Modems nicht....
Hole dir den 0.7.0 aus den normalen Quellen, der funktioniert.
..oder du machst ein Update auf 9.04, da läuft auch alles....

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 04.06.2009, 12:14    (Kein Titel) Antworten mit ZitatNach oben

Hi Webbutterfly,

danke für die rasche Antwort!

Ja der NWM ist aus den ppa-Repos.
Frage ist: wie gehe ich bei dem Downgrade am besten vor?

Muß ich wohl warten, bis ein Wired-LAN-Zugang möglich ist. Sonst schieß ich mich ja wohl aus dem Netz, wenn ich den NWM einfach mal deinstalliere um dann mit deaktivierten Repos wieder zu installieren - oder?

Hätte nämlich in Synaptic kein "Downgrade" finden können (Vergleich der Versionen mit deakt. Fremd-Quellen).

Das Upgrade auf 9.04 würde ich gerne machen, ist aber mit CrunchEee auf dem Netbook nicht ganz so einfach.

Ralf


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 04.06.2009, 13:21    (Kein Titel) Antworten mit ZitatNach oben

, ja ist nicht so einfach Sad

Lass mir etwas Zeit, ich werden Kontakt mit den Programmierern aufnehmen, vielleicht gibt es ein Lösung...
Wäre ja nicht das erste Mal... und damals haben sie recht schnell reagiert.

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 04.06.2009, 16:26    (Kein Titel) Antworten mit ZitatNach oben

Einfach mal "Danke, daß Du Dich der Sache annimmst!"

Ralf


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 05.06.2009, 09:55    (Kein Titel) Antworten mit ZitatNach oben

Hello

Nun, die Programmierer sind dran...
https://bugs.launchpad.net/ubuntu/jaunty/+source/network-manager/+bugs

https://bugs.launchpad.net/ubuntu/jaunty/+source/network-manager/+bug/360905

Es gibt da einen Patch... nur ich denke, der funktioniert nicht immer...ist vom 6.5.
https://bugs.launchpad.net/ubuntu/jaunty/+source/network-manager/+bug/360905/comments/8

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 05.06.2009, 13:16    (Kein Titel) Antworten mit ZitatNach oben

OK, Danke für die Info. Werde den Patch ggf. probieren.
Info ob es was gebracht/nicht gebracht hat (wenn ich probiere Very Happy ) kommt.

Ralf


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.06.2009, 17:00    Leider kein Erfolg Antworten mit ZitatNach oben

So - Versuch zu patchen ist erst mal gescheitert.
Ich stehe beim Versuch den Patch einzuspielen (soweit ich die Ausgaben des Terminal richtig interpretiere ...
ralf@PQMC-Mini:~/network-manager-0.7~~svn20081018t105859$ cd network-manager-*/
ralf@PQMC-Mini:~/network-manager-0.7~~svn20081018t105859/network-manager-0.7~~svn20081018t105859$ patch -p1 < /tmp/0030-core-only-match-serial-devices-when-filtering-on-or.patch
patching file src/nm-manager.c
Hunk #1 FAILED at 1160.
Hunk #2 FAILED at 1704.
2 out of 2 hunks FAILED -- saving rejects to file src/nm-manager.c.rej
ralf@PQMC-Mini:~/network-manager-0.7~~svn20081018t105859/network-manager-0.7~~svn20081018t105859$


Der Inhalt der nm-manager.c.rej ist wie folgt:
Zitat:

*************** nm_manager_get_device_by_udi (NMManager *manager, const char *udi)
*** 1160,1177 ****
return NULL;
}

- static NMDevice *
- nm_manager_get_device_by_originating_device (NMManager *manager, const char *od)
{
- GSList *iter;

for (iter = NM_MANAGER_GET_PRIVATE (manager)->devices; iter; iter = iter->next) {
const char *candidate_od = g_object_get_data (G_OBJECT (iter->data), ORIGDEV_TAG);

if (candidate_od && !strcmp (candidate_od, od))
- return NM_DEVICE (iter->data);
}
- return NULL;
}

static const char *
--- 1160,1177 ----
return NULL;
}

+ static GSList *
+ nm_manager_get_devices_by_originating_device (NMManager *manager, const char *od)
{
+ GSList *iter, *devs = NULL;

for (iter = NM_MANAGER_GET_PRIVATE (manager)->devices; iter; iter = iter->next) {
const char *candidate_od = g_object_get_data (G_OBJECT (iter->data), ORIGDEV_TAG);

if (candidate_od && !strcmp (candidate_od, od))
+ devs = g_slist_append (devs, G_OBJECT (iter->data));
}
+ return devs;
}

static const char *
*************** hal_manager_udi_added_cb (NMHalManager *hal_mgr,
*** 1704,1711 ****

/* Ignore multiple ports for serial devices */
if (general_type == NM_TYPE_SERIAL_DEVICE) {
- if (nm_manager_get_device_by_originating_device (self, originating_device))
- return;
}

device = creator_fn (hal_mgr, udi, originating_device, nm_manager_udi_is_managed (self, udi));
--- 1704,1721 ----

/* Ignore multiple ports for serial devices */
if (general_type == NM_TYPE_SERIAL_DEVICE) {
+ GSList *devices, *iter;
+
+ devices = nm_manager_get_devices_by_originating_device (self, originating_device);
+ for (iter = devices; iter; iter = g_slist_next (iter)) {
+ NMDevice *candidate = NM_DEVICE (iter->data);
+
+ if (candidate && NM_IS_SERIAL_DEVICE (candidate)) {
+ g_slist_free (devices);
+ return;
+ }
+ }
+ g_slist_free (devices);
}

device = creator_fn (hal_mgr, udi, originating_device, nm_manager_udi_is_managed (self, udi));


Die Hunk-Meldungen sagen mir halt gar nix und auch in den Kommentaren auf den Launchpad-Seiten konnte ich nix dazu finden.

Zur Methode: Bin dabei wie in https://bugs.launchpad.net/ubuntu/jaunty/+source/network-manager/+bug/360905/comments/8 beschrieben vorgegangen, aber es sollte wohl nicht sein.

Wenn ich dann Versuche trotzdem das Paket zu erzeugen bricht die Geschichte wegen sehr vieler ungelöster Abhängigkeiten ab:
ralf@PQMC-Mini:~/network-manager-0.7~~svn20081018t105859/network-manager-0.7~~svn20081018t105859$ dpkg-buildpackage -rfakeroot -b
dpkg-buildpackage: setze CFLAGS auf Standardwert: -g -O2
dpkg-buildpackage: setze CPPFLAGS auf Standardwert:
dpkg-buildpackage: setze LDFLAGS auf Standardwert: -Wl,-Bsymbolic-functions
dpkg-buildpackage: setze FFLAGS auf Standardwert: -g -O2
dpkg-buildpackage: setze CXXFLAGS auf Standardwert: -g -O2
dpkg-buildpackage: Quellpaket network-manager
dpkg-buildpackage: Quellversion 0.7~~svn20081018t105859-0ubuntu1.8.10.2
dpkg-buildpackage: Quellen geändert durch Marc Deslauriers <marc.deslauriers@ubuntu.com>
dpkg-buildpackage: Host-Architektur i386
dpkg-checkbuilddeps: Nicht erfüllte Bauabhängigkeiten: debhelper (>= 5.0.0) automake1.9 cdbs quilt gnome-common intltool libgnome-keyring-dev libdbus-glib-1-dev (>= 0.74) libiw-dev (>= 27+28pre9) libgnomeui-dev libpanel-applet2-dev libglade2-dev libgconf2-dev libhal-dev (>= 0.5.0) libnl-dev (>= 1.0~pre8) libnotify-dev (>= 0.3) libpolkit-dbus-dev libnss3-dev docbook-to-man ppp-dev gtk-doc-tools uuid-dev
dpkg-buildpackage: Warnung: Bauabhängigkeiten/-konflikte nicht erfüllt; Abbruch
dpkg-buildpackage: Warnung: (Verwenden Sie -d, um sich darüber hinwegzusetzen.)
ralf@PQMC-Mini:~/network-manager-0.7~~svn20081018t105859/network-manager-0.7~~svn20081018t105859$

Rolling Eyes

Mal sehen, vielleicht bekommen die Herren und Damen wink Entwickler die "G'schichte" ja eh bald in den Griff. (obwohl lästig ist der Fehler schon)

Ralf


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 08.06.2009, 20:37    Downgrade Antworten mit ZitatNach oben

« Webbutterfly » hat folgendes geschrieben:
, ja ist nicht so einfach Sad

Lass mir etwas Zeit, ich werden Kontakt mit den Programmierern aufnehmen, vielleicht gibt es ein Lösung...
Wäre ja nicht das erste Mal... und damals haben sie recht schnell reagiert.

Marion


@ Marion:

Jetzt frag ich doch noch an, ob es nicht eine Möglichkeit ist z.B. die Pakete
network-manager-gnome_0.7~~svn20081020t000444-0ubuntu1.8.10.2_i386.deb und
network-manager_0.7~~svn20081018t105859-0ubuntu1.8.10.2_i386.deb
und die lib-nm's
(die ich von den Ubuntu Seiten heruntergeladen habe) wieder ein zu spielen, indem ich die beiden Pakete aus den PPA-Repos via Synaptic (die Konfiguration würde ich behalten) deinstalliere und dann den NWM aus den (lokal kopierten) debs wieder einspiele?
Was meinst dazu?


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 08.06.2009, 21:10    (Kein Titel) Antworten mit ZitatNach oben

Hello

Ja, kannst du machen... falls Abhängigkeiten fehlen, bekommst du ja Informationen beim installieren...
bzw. hier kannst du dir ja mal die Abhängigkeiten ansehen

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 08.06.2009, 21:47    Problem noch nicht gelöst, aber ... Antworten mit ZitatNach oben

... Downgrade geschafft!

Hat nur die De- und Reinstallation der beiden NWM-Pakete benötigt. Die lib's waren nicht notwendig.
Ein Reboot noch und schon wird das Modem wieder erkannt. Alle Einstellungen und etc. sind (da ich nicht "mit Konfigurationsdateien" gelöscht habe natürlich) auch noch da.

Das löst zwar nicht den "Knopf" im NWM 0.7.1, aber mein Problem ist erst mal nicht mehr besonders "vakant" Very Happy

Ralf


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 18.06.2009, 20:55    (Kein Titel) Antworten mit ZitatNach oben

Jo - das Modem wird erkannt, aber connecten funktioniert nicht. :-(

Also auch nicht besser im Endergebnis.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050214450 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.3393s (PHP: 89% - SQL: 11%) | SQL queries: 80 | GZIP enabled | Debug off ]