Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 (gelöst) GRUB2-Bootmenü unsichtbar machen

Dieses Forum ist gesperrt, du kannst keine Beiträge editieren, schreiben oder beantworten.Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.
Autor Nachricht
NeverAgain
Gast










BeitragVerfasst am: 01.04.2010, 17:34    (gelöst) GRUB2-Bootmenü unsichtbar machen Antworten mit ZitatNach oben

So, ...nun habe ich mir die Mühe gemacht von 9.04 auf 9.10 zu aktualisieren, wobei ich auf von GRUB Legacy auf GRUB2 scheinbar erfolgreich upgradete (<- dieses deutsch/englisch, tztz).

Nun würde ich gerne das Boot-Menü, in welchem Ubuntu 9.10, Ubuntu 9.10 recovery, memtest und Windows XP zu Auswahl steht, unsichtbar machen.
D.h. es ist nicht zu sehen, aber wenn ich es brauche, um z.B. doch einmal auf Windows zuzugreifen, mittels Shift-Taste (ewie in Wikis beschrieben) das Menü sichtbar wird und ich die Auswahl tätigen kann.

Ich habe in eingen Wikis gelesen, dass man in /etc/default/grub
#GRUB_HIDDEN_TIMEOUT=0 das # davor löscht und eine entsprechende Zeit von z.B. 5 Sekunden angibt:
ergo: GRUB_HIDDEN_TIMEOUT=5

Das habe ich auch so gemacht,
dann "sudo update-grub" im Terminal
Neustart

... und dann die lange Nase:
Das Boot-Menü ist weiter sichtbar!

Hab ich irgend etwas vergessen?

P.S.: Habe GRUB_TIMEOUT= auch auf 5 Sekunden gesetzt
ergo GRUB_TIMEOUT=5
Das erschien mir logisch: GRUB_HIDDEN_TIMEOUT=5 <-> GRUB_TIMEOUT=5

Achja, ...ist vielleicht auch erwähnenswert:
in /etc/grub.d/05_debian_theme steht:
set color_normal=black/black
set color_highlight=magenta/black
Bei mir erscheint das Menü mit weißer Schrift auf schwarzen Bildschirm bzw. bei Hervorhebungen: schwarze Schrift mit weißem Highlight (nix mit magenta) auf schwarzen Bilschirm

Nun, hat jemand eine Idee?

LG
Mario


Zuletzt bearbeitet von NeverAgain am 01.04.2010, 18:17, insgesamt einmal bearbeitet


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit


Zuletzt bearbeitet von NeverAgain am 01.04.2010, 18:17, insgesamt einmal bearbeitet
Online    
kappa




Geschlecht:
Alter: 47
Anmeldungsdatum: 26.10.2009
Beiträge: 1466
Wohnort: Wien 10


austria.gif

BeitragVerfasst am: 01.04.2010, 17:43    (Kein Titel) Antworten mit ZitatNach oben

Es gibt im /etc/default/grub mindestens zwei TIMEOUT Variablen, die Du beide auf =0 stellen mußt, erst dann erscheint das Menü "nicht", den DEFAULT mußt Du natürlich auf Ubuntu (setzen/bleiben) lassen.

Such mal hier im Forum, ich hab das mal schon genauer beschrieben.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0


dann "sudo update-grub" im Terminal


Desktop: Gnome 2.X

Version: 10.04

Hardware: Notebook

Architektur: 32Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
NeverAgain
Gast










BeitragVerfasst am: 01.04.2010, 17:54    (Kein Titel) Antworten mit ZitatNach oben

Hallo, Hannes!

Wenn ich GRUB_HIDDEN_TIMEOUT= auf 0 setze, dann habe ich ja keine Zeit mittels Shift-Taste das Menü aufzurufen. ...oder habe ich da eine Denkfehler?
Analoges kann ich mir bei GRUB_TIMEOUT=0 vorstellen. Es wäre das Menü nur 0 Sekunden auswählbar


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
kappa




Geschlecht:
Alter: 47
Anmeldungsdatum: 26.10.2009
Beiträge: 1466
Wohnort: Wien 10


austria.gif

BeitragVerfasst am: 01.04.2010, 17:55    (Kein Titel) Antworten mit ZitatNach oben

Vertraue mir, Du fängst mit Shift den Grub ab, das reicht schon.

Desktop: Gnome 2.X

Version: 10.04

Hardware: Notebook

Architektur: 32Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
NeverAgain
Gast










BeitragVerfasst am: 01.04.2010, 18:02    (Kein Titel) Antworten mit ZitatNach oben

... Dein "Vertrau mir..." erinnert mich an eine Comedy-Serie. ...vielleicht kennst Du diese: "Kommisar Hammer"
...der meinte auch immer: Vertrauen Sie mir! Ich weiß, was ich tue.
Entsprechend lustig waren dann die Ergebnisse wink

Aber ich werde Dir vertrauen.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
kappa




Geschlecht:
Alter: 47
Anmeldungsdatum: 26.10.2009
Beiträge: 1466
Wohnort: Wien 10


austria.gif

BeitragVerfasst am: 01.04.2010, 18:14    (Kein Titel) Antworten mit ZitatNach oben

Genau von da kommt es her. Smile

Wenn Du nur auf der Shift Taste bleibst, dann regt sich wieder (zB mein) BIOS auf. Mußt einen Mittelweg finden.

Hammerrrrrr!


Desktop: Gnome 2.X

Version: 10.04

Hardware: Notebook

Architektur: 32Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
NeverAgain
Gast










BeitragVerfasst am: 01.04.2010, 18:16    (Kein Titel) Antworten mit ZitatNach oben

Das war mal wieder ein Beispiel dafür, dass sich einfach fallen lassen und vertrauen soll. ......da wird Ubuntu zu Philosophie :-)

Es funktioniert!

Danke, Hannes


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Dieses Forum ist gesperrt, du kannst keine Beiträge editieren, schreiben oder beantworten.Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050158428 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.0871s (PHP: 73% - SQL: 27%) | SQL queries: 55 | GZIP enabled | Debug off ]