Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Minicom und USB-Modem

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 22.04.2010, 06:30    Minicom und USB-Modem Antworten mit ZitatNach oben

Diverse AT Kommandos haben mit meinem Huawei E160E funktioniert.
Ich kann jedoch keine Tipps für andere Modelle geben.


Zuletzt bearbeitet von Gast am 28.04.2010, 22:26, insgesamt einmal bearbeitet


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit


Zuletzt bearbeitet von Gast am 28.04.2010, 22:26, insgesamt einmal bearbeitet
Online    
Gast











BeitragVerfasst am: 22.04.2010, 07:58    (Kein Titel) Antworten mit ZitatNach oben

« kappa » hat folgendes geschrieben:
Die Zauberformel - jetzt ist sie fällig!
[...]
@mwildam: Bin in Wien,10., also wenn Zeit da ist gerne! Smile

Cool, werde ich probieren.
Kleine Frage dazu: Dh, unter Windows meldet das Teil dann auch nicht mehr als CD und ist mit den Einstellungen unbrauchbar, oder? - Nicht das mich das persönlich jucken würde, ich arbeite auch beruflich auf Linux, aber wenn jemand Dual fährt, wäre das dann wahrscheinlich zu bedenken, richtig?

Warst Du beim letzten Stammtisch dabei?


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 22.04.2010, 09:26    (Kein Titel) Antworten mit ZitatNach oben

Nein, sollte nur das Fake CD Laufwerk deaktivieren, dort ist eh nur veraltete Win Software oben, die man auch unter Windows später nicht mehr braucht.

Ja, ich war am Stammtisch, Du hast mir das FreeDOS gegeben, ich hab die Bootversuche damit verbrochen, danke nochmals für die Hilfe.
(FreeDOS hatte leider zuwenig Treiber mit.)


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 26.04.2010, 20:55    (Kein Titel) Antworten mit ZitatNach oben

« kappa » hat folgendes geschrieben:
Die Zauberformel - jetzt ist sie fällig!

Zauberer zeigen Illusionen... gezaubert wird da nichts.
Nee, die funktioniert nicht...
Da ich kein /dev/ttyUSB0 habe, kann ich das Modem auch nicht ansprechen...
Minicom sagt mir /dev/tty8, nur da funztz auch nicht...
Sorry, deine Beschreibung ist auch nicht wirklich gut Wink

Habe gerade ein E1552 zur Hand...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 27.04.2010, 04:38    (Kein Titel) Antworten mit ZitatNach oben

Da läuft ja was gröber schief!

Ich weiß, daß manche UMTS Modems nicht als USB Modems erkannt werden, dann bekommen sie kein ttyUSB0.

Willst Du mir sagen, daß Dein E1552 mit neuem Ubuntu nicht funkt, und daß es mit älterem zB 9.10 auch kein ttyUSB0 kriegt?

Was sagt denn lsusb? Im Kernel Log muß ja was stehen, wenn ich dem Ubuntu ein USB-Zäpfchen verpasse.

Kannst Du mal manuell mit "modeprobe usbserial ..." (siehe Link) machen? Gibts jetzt ein ttyUSB0?

https://wiki.ubuntu.com/NetworkManager/Hardware/3G/Probing

Wegen meiner Beschreibung:
Daß ein Huawei Modem nicht mal ein ttyUSB0 verpaßt bekommt, das muß ich doch nicht vorausahnen. Wie ein minicom funktioniert habe ich beschrieben. Wie das ominöse Huawei AT Kommando heißt, auch. Fehlt nur noch ein Screencast. Smile

P.S. Verwende das Huawei mal ohne Kabel, schau, daß sonst keine USB Sticks und Geräte dran stecken.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 27.04.2010, 11:40    (Kein Titel) Antworten mit ZitatNach oben

Bin leider immer noch nicht dazugekommen, das auszuprobieren - aber in Launchpad ist der Bug als Confirmed gekennzeichnet, also irgendein Problem gibt es auf jeden Fall damit. Immerhin funktioniert das E1552 unter 9.10 ohne Probleme und Quirks.

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 27.04.2010, 22:36    (Kein Titel) Antworten mit ZitatNach oben

Leute, Leute, jetzt wirds langsam peinlich.

Ich habe gelesen, daß der Entwickler von usb-modeswitch den modem-modeswitch beerben will, weil da nix weitergeht.

Die Hoschis bei Canonical müssen sich endlich mal am Schopf nehmen, wenn sie dem Windows ein desktoptaugliches Ubuntu entgegenstellen wollen.

Dieser Schmarrn mit *-modeswitch und Networkmanager ist wirklich nicht mehr Mirkosoft in die Schuhe zu schieben, sondern selbstverzapfter Schrott - Crap!

Dabei ist aus meiner Sicht die Lage so einfach zu bereinigen: Ein AT Kommando und alles ist wieder gut!
Vielleicht können wir am Stammtisch sowas durchexerzieren - für einen ansonst hoffnungslosen Huawei-Fall.

@martin: Was ist jetzt? Willst Du Dich mit einem Ubuntu Bugreport begnügen, oder funktioniert hier auch ein aktuelles usb-modeswitch? Oder probierst Du einfach mal ein AT-Kommando, welches den Stick dauerhaft und rechnerübergreifend kompatibel macht?

@webbutterfly: Auch wenns mit usb-modeswitch klappt und somit für die meisten Anwender so am besten zu lösen ist, vor allem dann, wenn usb-modeswitch ins udev einziehen sollte, so möchte ich trotzdem das mal testen ohne einen Stick bei Hofer kaufen zu müssen.

Kurzanleitung:
minicom in Fahrt bringen, chat verträgt kein AT^. (hmm, vielleicht mit Hochkomma und Backslash irgendwie escapen?)
Kleinschreibung ok.
Paar AT Kommandos absetzen (Hestellerinfo und S-Registerbelegung):
AT
ATI
AT&V

AT^U2DIAG=256
AT

Ausstieg mit "Strg-a x" , dann Stick abstecken/anstecken.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 28.04.2010, 08:53    (Kein Titel) Antworten mit ZitatNach oben

Ich würde das Ganze mit Vorsicht sehen, da damit möglicher Weise ein Garantieverlust verbunden ist..
Mit dieser Methode wird die Firmwareeinstellung am Modem geändert...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 28.04.2010, 21:54    (Kein Titel) Antworten mit ZitatNach oben

Ok, ich kapituliere.
Ich wollte es am Stammtisch testen , ist nichts geworden.
Die Anleitung ist auch nicht für alle Modelle gleich.
Der Modemmanager kann das Modem auch gerade blockieren, mehrmals versuchen ist ok.

Jetzt ist mir lieber wir streichen das ganze aus dem Protokoll.
Mir ist das durchaus recht, ein Standardverfahren gibt's leider nicht.
Bitte weg damit.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 29.04.2010, 03:13    (Kein Titel) Antworten mit ZitatNach oben

« kappa » hat folgendes geschrieben:
Die Hoschis bei Canonical müssen sich endlich mal am Schopf nehmen, wenn sie dem Windows ein desktoptaugliches Ubuntu entgegenstellen wollen.

Ja, das denke ich mir auch manchmal.

« kappa » hat folgendes geschrieben:
Dabei ist aus meiner Sicht die Lage so einfach zu bereinigen: Ein AT Kommando und alles ist wieder gut!

Sorry, aber bei mir scheitert es schon daran, daß ich keines der von Dir angegebenen Devices bei mir nach Anstecken des Modems finden kann.

Folgende kriege ich dazu, wenn ich das Modem anstecke: cdrom1, scd1, sg2, sg3, sr1

Und jetzt? Echt eine Qual der Wahl.
Die Variante habe ich also vorerst aufgegeben.

Habe usb_modeswitch ausprobiert und damit funktioniert es bei mir, allerdings nicht wirklich verlässlich - habe aber noch nicht herausgefunden, woran es liegt.
BTW: Das usb_modeswitch scheint man ja nur einmal zu brauchen, oder? - Jedenfalls scheint sich das Lucid (oder vielleicht auch schon Vorversionen) dann zu merken, wenn ich usb-modeswitch installiert und einmal usb_modeswitch aufgerufen habe. - in lsusb identifiziert es sich dann immer als modem.

« kappa » hat folgendes geschrieben:
@martin: Was ist jetzt? Willst Du Dich mit einem Ubuntu Bugreport begnügen, oder funktioniert hier auch ein aktuelles usb-modeswitch? Oder probierst Du einfach mal ein AT-Kommando, welches den Stick dauerhaft und rechnerübergreifend kompatibel macht?

Mein erster Wunsch wäre, daß der Bug gefixt wird. Bei Karmic habe ich noch nicht beim Beta-Test mitgemacht und etliche Modems gingen beim Release nicht (Fixes wurden erst später nachgereicht). Ich wollte mitmachen, um hier die Qualität der Releases zu verbessern - habe mir extra deswegen ein zweites Modem gekauft, obwohl ich ja eh schon ein funktionierendes hatte (ok, ich wollte es auch als Backup wink ).

Wenn es einen Workaround gibt, kann ich für mich damit leben, würde das aber natürlich schlechter fürs Ubuntu-Image finden - weil sagen ja viele, daß Linux "Commandline-Gefrickel" ist.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050186427 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1134s (PHP: 72% - SQL: 28%) | SQL queries: 70 | GZIP enabled | Debug off ]