Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Huawei: keine CD mehr mit Einzeiler

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 28.04.2010, 00:16    Huawei: keine CD mehr mit Einzeiler Antworten mit ZitatNach oben

Hurra, ich habs geschafft, ohne minicom, und mit chat:
Funktioniert hat es nur mit E160E, und dort ist es nicht mehr zwingend nötig.
Also vergeßt es.


Zuletzt bearbeitet von Gast am 28.04.2010, 22:28, insgesamt einmal bearbeitet


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit


Zuletzt bearbeitet von Gast am 28.04.2010, 22:28, insgesamt einmal bearbeitet
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 28.04.2010, 09:05    (Kein Titel) Antworten mit ZitatNach oben

...ein sudo vor dem Befehl ist vollkommen ausreichend:
sudo chat  -sv "" AT OK 'AT\^U2DIAG=256' OK >/dev/ttyUSB0 </dev/ttyUSB0

..ich würde, um permanent sudo zu sein, auch den Befehl
sudo -s
nicht -i
empfehlen.

PS: mit dem E1552 getestet, ohne usb-modeswitch... funktioniert.

Marion


Zuletzt bearbeitet von Webbutterfly am 03.08.2010, 10:20, insgesamt einmal bearbeitet


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com



Zuletzt bearbeitet von Webbutterfly am 03.08.2010, 10:20, insgesamt einmal bearbeitet
OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 28.04.2010, 09:12    Nö Antworten mit ZitatNach oben

Hi kappa,

habe sofort (wieder mal ohne zu wissen was ich da tue) bei einem HUAWEI E220 Deinen Vorschlag abgetippt, und bin leider auf das folgende gestoßen:
root@PQMC-Work:~# chat -sv "" AT OK 'AT\^U2DIAG=256' OK >/dev/ttyUSB0 </dev/ttyUSB0
send (AT^M)
expect (OK)
AT^M^M
OK
 -- got it

send (AT\^U2DIAG=256^M)
expect (OK)
^M
AT^U2DIAG=256^M^M
ERROR^M
alarm
Failed
root@PQMC-Work:~#

Question Rolling Eyes

"Zerst mag er mich ... und dann zeigt er mir die lange Naase ..." Confused


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 28.04.2010, 09:21    (Kein Titel) Antworten mit ZitatNach oben

Das Ganze mit VORSICHT > Möglicher Weise Garantieverlust!
Mit einem E160 getestet:
sudo chat  -sv "" AT OK 'AT\^U2DIAG=256' OK >/dev/ttyUSB0 </dev/ttyUSB0
[sudo] password for ubuntu:
send (AT^M)
expect (OK)
AT^M^M
OK
 -- got it

send (AT\^U2DIAG=256^M)
expect (OK)
^M
AT^U2DIAG=256^M^M
OK
 -- got it


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 28.04.2010, 09:28    (Kein Titel) Antworten mit ZitatNach oben

Smile
Das 220 ist "schon a bissal aus da Garantie" - da gibt's nichts mehr zu verlieren! Laughing

Würde trotzdem gerne wissen, warum diese Kiste wieder den Befehl nicht annimmt. Question

Ralf


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 28.04.2010, 09:38    (Kein Titel) Antworten mit ZitatNach oben

...geht auch bei meinem E220 nicht...

Nochmals ACHTUNG... dies sind ist alles undokumentiert... heißt also, dass es auch daneben gehen kann.

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 28.04.2010, 09:51    (Kein Titel) Antworten mit ZitatNach oben

« Webbutterfly » hat folgendes geschrieben:
...geht auch bei meinem E220 nicht...

Wenn es auch meine Frage nicht beantwortet, so "beruhigt" es doch - dann bin wenigstens nicht ich der Dödel, sondern die Hardware ist schuld! Very Happy


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050216659 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.2596s (PHP: 15% - SQL: 85%) | SQL queries: 55 | GZIP enabled | Debug off ]