Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Problem mit einer A1 umts verbindung

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 07.07.2010, 11:39    Problem mit einer A1 umts verbindung Antworten mit ZitatNach oben

Ich muss für die Arbeit ein Lenovo s10 netbook (eingebeutes modem)
mit internet ausstatten.
Ich hab mich die letzten zwei tage durchs Forum gekämpft und bin auch ziehmlich weit gekommen...
Gestern hat es sogar geklappt und ich hatte Internet (mit dem befehl sudo wvdial) aber heute funktioniert wieder nichts:

Ich bekomm als Fehlermeldung "The PPP daemon has died: A modem hung up the phone (exit code = 16)"

hier mein wvdial.conf
[Dialer Defaults]
Stupid Mode = on
Modem = /dev/ttyACM0 
Init1 = at+cgdcont=1,"IP","A1.net"
Phone = *99***1#
Username = ppp@A1plus.at
Password=ppp


Hier die Fehlermeldung:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
OK
--> Sending: at+cgdcont=1,"ip","a1.net"
at+cgdcont=1,"ip","a1.net"
OK
--> Sending: at+cbst=71,0,1
at+cbst=71,0,1
OK
--> Modem initialized.
--> Sending: ATM0L0DT*99***1#
--> Waiting for carrier.
ATM0L0DT*99***1#
~[7f]}#@!}!}!} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&[1d] ta};[12]~
CONNECT

--> Carrier detected.  Waiting for prompt.
~[7f]}#@!}!}"} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&[1d] taW[7f]~
--> PPP negotiation detected.
--> Starting pppd at Wed Jul  7 11:11:36 2010
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 2367
--> Using interface ppp0
--> Disconnecting at Wed Jul  7 11:11:36 2010
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for
more information.


Ich hoffe wirklich das ihr mir da helfen könnt!
Mit freundlichen Grüßen


Edit by Admin: Bitte und verwenden!


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 11:50    (Kein Titel) Antworten mit ZitatNach oben

Schön nach der Reihe:
Hast Du auch ein integriertes Ericsson so wie ich?
(Output vom Kommando lspci zeigt Hersteller.)

Was fällt Dir an dieser Meldung auf?

Zitat:
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 11:53    (Kein Titel) Antworten mit ZitatNach oben

Ja ein Ericsson F3507g

ja wenn ich sudo wvdial eingib hab ich zwar kein Permission problem aber der PPP deamond died trotzdem


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 11:58    (Kein Titel) Antworten mit ZitatNach oben

PIN deaktivieren
System Logs anschauen (geht auch via Gnome Menü)

Wenn Du bei einem File ein "Permission Denied" zurück bekommst, dann hast Du mit zuwenig Rechten darauf zugegriffen.

Also, wvdial mit root-Rechten starten, vermutlich also
sudo wvdial
verwenden.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 12:18    (Kein Titel) Antworten mit ZitatNach oben

Ich würde Dir raten mal ohne wvdial zu arbeiten, dieses Ericsson Modell ist mit Network Manager unterstützt.

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 12:25    (Kein Titel) Antworten mit ZitatNach oben

ja wenn ich sudo wvdial ausführe bekomm ich zwar kein "Permission Denied" aber noch immer einen "PPP deamond died"
das modem wird zwar vom netzwerkmaneger unterstütz aber baut nur ewig eine Verbindung auf und bricht dann grundlos ab...


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 12:28    (Kein Titel) Antworten mit ZitatNach oben

Im NWM unbedingt mit fixen DNS Adressen arbeiten, das ist ein bekanntes Leiden des DHCP.
Vielleicht ist wvdial doch besser , mehr Kontrolle.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 12:41    (Kein Titel) Antworten mit ZitatNach oben

ok jetzt hats kurz funtionierts:

hab mit chmod die zugriffsrechte auf etc/ppp/pap-secrets
(:~$ ls -al /etc/ppp/pap-secrets
-rwsr-sr-x 1 root root 1730 2010-07-07 11:54 etc/ppp/pap-secrets
und habs dann mit gnome PPP verbunden hab!!!

nach einem Neustart funktionierts jedoch nichtmehr
Gnome schreibt "verbinde" / "Wähle" und dann "Warte auf Eingabeaufforderung" und dann passiert nichts vorher ist das kleiche passiert nur das fenster is verschwunden und ich hatte Internet!
pap-secrets hab ich schon überprüft, is noch immer
-rwsr-sr-x 1 root root 1730 2010-07-07 11:54 etc/ppp/pap-secrets


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 12:57    (Kein Titel) Antworten mit ZitatNach oben

Hmm,

PIN deaktivieren
fixe DNS Adressen
zum Stammtisch kommen
Systemlogs checken (geht auch via Gnome Menü)
mit wvdial interaktive Checks machen
höheren Kernel Patchlevel nehmen

Würd mich echt interessieren, doch Du bist in Graz zuhause, nicht Wien oder?


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 13:01    (Kein Titel) Antworten mit ZitatNach oben

leider graz

ich bin jetzt draufgekommen wie ich eine internetverbindung herstell...warum es genau so geht weiß ich auch nicht!!

Nach einem Neustart öffne ich gnome ppp und versuch zu verbinen bei der Modemerkennung zeigt er ttyACM0 an)--> nichts passiert

danach geh ich zum NWM und versuch dort eine verbindung herzustellen -->Nichts

dann zurück zu gnome ppp und modem erkennen (jetzt ttyACM1) und wieder verbinden--> FUNKTIONIERT

Warum und kann ich das iwie abkürtzen??


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 07.07.2010, 13:04    (Kein Titel) Antworten mit ZitatNach oben

« kappa » hat folgendes geschrieben:
Würd mich echt interessieren, doch Du bist in Graz zuhause, nicht Wien oder?

Tja, wieder der Hinweis der Administratorin:
Zitat:
Als WOHNORT ist der Ort in dem gewohnt wird, in Wien mit Bezirk, anzugeben.
Kein Staat, Bundesland, Postleitzahl oder "irgendwo" auch keine Strasse, ganz einfach der Wohnort.

...hat also seinen Grund wie ihr seht...
Wer lesen kann(tut) ist meistens besser dran.

Admin

EDIT: ...hat gewirkt Smile


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 07.07.2010, 14:32    (Kein Titel) Antworten mit ZitatNach oben

Tja, ttyACM0/1 (ttyUSB0/1) ...
Das sollte der Modemmanager für den NWM erledigen.
Man kann das mit UDEV Rules beeinflussen.

Doch ohne einem Musterbeispiel wirds ein Herumprobieren.

Eventuell ist es schon in (Paket) usb-modeswitch eingebaut.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 07.07.2010, 14:36    (Kein Titel) Antworten mit ZitatNach oben

ja ich werd einfach so lassen...hauptsache ist es funktioniert!

Dennoch Danke für die schnelle und gute Beratung hier wink

MfG


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 25.08.2010, 18:25    (Kein Titel) Antworten mit ZitatNach oben

Ich habs mit Network Manager + einem AT-Kommando gelöst
und hoffe auf einen baldigen Fix (im MM oder NM?).

http://www.ubuntu-austria.at/viewtopic.php?p=14738#14738
(ganz unten!)


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050179206 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.2064s (PHP: 82% - SQL: 18%) | SQL queries: 90 | GZIP enabled | Debug off ]