Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 [gelöst]Grub2-Boot-Menü nach Aktualisierung

Dieses Forum ist gesperrt, du kannst keine Beiträge editieren, schreiben oder beantworten.Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.
Autor Nachricht
Beginner




Geschlecht:
Alter: 40
Anmeldungsdatum: 06.02.2010
Beiträge: 387
Wohnort: Graz


austria.gif

BeitragVerfasst am: 26.10.2010, 15:18    [gelöst]Grub2-Boot-Menü nach Aktualisierung Antworten mit ZitatNach oben

Hallo,

ich hätte da eine Frage zum Grub2-Boot-Menü. Meinen "alten" Medion-Rechner, bei dem ich ja diese Schwierigkeiten mit der Nvidia Grafik Karte hatte, hab ich meinen Eltern überlassen.

Ich hab das System soweit unverändert übergeben: Dual-Boot mit Windows XP und Ubuntu 10.04. Windows XP für meine Eltern und Ubuntu für mich, sollte ich was brauchen.

Als Erleichterung für meine Eltern hab ich Grub so konfiguriert, dass als Default OS im Boot-Menü Windows ausgewählt wird und nach einer definierten Zeit X auch startet.

In /etc/default/grub hab ich GRUB_DEFAULT= auf jenen Wert gesetzt, welcher zu dem damaligen Zeitpunkt der Menüpunkt "Windows XP" entsprochen hat.

Jetzt hab ich aber das "Problem", dass bei einer Aktualisierung mit einem neuen Kernel dieser Menüeintrag nach unten rutscht und damit die "Default"-Einstellung nicht mehr stimmt.

Besteht eine Möglichkeit das so zu konfigurieren, dass das mit den Aktualisierungen "mitwächst" bzw. überzuckert: halt da sind zwei neue Einträge für den neuen Kernel dazu gekommen, also ist Windows XP um 2 Einträge nach unten gewandert.

Ich hab auch versucht in GRUB_DEFAULT="xxx" exakt jene Bezeichnung in "" zu setzten, wie er im Boot-Menü aufscheint (Skript: 30_os-prober). Hat leider auch nicht den gewünschten Erfolg gebracht.

Danke im Voraus

lg
hansjürgen


Zuletzt bearbeitet von Beginner am 08.11.2010, 12:13, insgesamt einmal bearbeitet


Desktop: LXDE Lubuntu and anderer

Version: 14.04 and 16.04

Hardware: Workstation and Notebook

Architektur: 32Bit and 64Bit

_________________
Desktop-Rechner
- DELL Inspiron 570MT, AMD Athlon II X4 630 (2,8GHz, 2MB), 8GB RAM, ATI Radeon HD5450, DeLL 20" Monitor IN2010N
- OS: Ubuntu Mate 16.04. (64Bit)

Notebook:
- Chiligreen Platin SE Notebook
- Dual Boot (LUbuntu14.04 (32Bit) + Windows 7)

Benutzer:
Windows geschädigter Linux-Neuling


Zuletzt bearbeitet von Beginner am 08.11.2010, 12:13, insgesamt einmal bearbeitet
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 26.10.2010, 16:20    (Kein Titel) Antworten mit ZitatNach oben

Sorry, eine etwas blöde Frage..

Wenn es so eingestellt ist, dass Windose immer automatisch bootet, wann wird dann Ubuntu gewählt?

Ich halte es für sinnlos, lass Windose alleine drauf, wenn es "Standard" ist... oder eben Ubuntu. So sehe ich das Dualboot als sehr sinnlos und auch noch mit Problemen behaftet.

Sorry, ich bin für "entweder Windose oder Linux" man sollte sich entscheiden und bei einem bleiben. Mixrechner sind nur was für Leute die.... ich weiß nicht, sicher nicht für alleinige Nutzer des/eines Systems.
Ich habe keinen und meine Kunden arbeiten problemlos mit Ubuntu alleine.... Dualboot würde ich auch nicht installieren, wo zu?

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
kappa




Geschlecht:
Alter: 47
Anmeldungsdatum: 26.10.2009
Beiträge: 1466
Wohnort: Wien 10


austria.gif

BeitragVerfasst am: 26.10.2010, 17:40    (Kein Titel) Antworten mit ZitatNach oben

Hallo, melde mich aus der sonnigen Ferne!

Ich verstehe die Position Dualboot Systeme vermeiden zu wollen.
Nur der letzte Beitrag hier klingt wie ein hartes Infragestellen des Dualboot, und das verstehe ich jetzt nicht mehr bzw. kann ich so nicht teilen.

Zur Sache selbst:
Der Ansatz ist richtig. Einfach den Titel des Menüpunkts exakt als Defaultboot-Text verwenden.

Bloß ich sehe hier keine genaue Beschreibung, wie die Modifikation abgelaufen ist und wie die entsprechenden Zeilen in der daraus generierten grub.cfg nun aussehen.

P.S. Windows ist nur der Defaultboot-Eintrag, der autom. gestartet wird, wenn zB 10sec ohne andere Wahl (zB Ubuntu) vergangen sind.


Desktop: Gnome 2.X

Version: 10.04

Hardware: Notebook

Architektur: 32Bit

_________________
Firma: Lenovo T410 10.04 32bit (Intel IGP 1440x900, Intel SSD)
Privat: Lenovo T500 10.04 32bit (Intel IGP 1680x1050, Seagate FDE)
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Beginner




Geschlecht:
Alter: 40
Anmeldungsdatum: 06.02.2010
Beiträge: 387
Wohnort: Graz


austria.gif

BeitragVerfasst am: 26.10.2010, 18:26    (Kein Titel) Antworten mit ZitatNach oben

@Webbutterfly: ui, da gehst aber hart mit mir ins Gericht. Wie gesagt, der PC ist deshalb so aufgesetzt, weil es "noch" Dinge gibt, für die ich unter Linux leider keinen Ersatz gefunden habe (-> siehe meine Frage in diesem Forum ob es unter Linux ein NERO ähnliches Programm gibt mit Cover-Funktion)
Nachdem der Computer ja so weit schon so "hergerichtet" war, hab ich nicht viel daran geändert und das so belassen. Und meinen Eltern erspar ich den Umbstieg, weil von Ihnen auch nicht gewollt. Und was der Mensch nicht will, von dem ist der halt schwer zu Überzeugen.

@Kappa: tut mir leid, hätte ich mitposten können, hab ich nicht daran gedacht. Mittlerweile bin ich wieder ein paar km vom PC entfernt, wenn der nä. Besuch ansteht bei den Eltern, dann hole ich das nach.

lg (vor allem in die sonnigen Regionen dieser Erde)
jürgen


Desktop: LXDE Lubuntu and anderer

Version: 14.04 and 16.04

Hardware: Workstation and Notebook

Architektur: 32Bit and 64Bit

_________________
Desktop-Rechner
- DELL Inspiron 570MT, AMD Athlon II X4 630 (2,8GHz, 2MB), 8GB RAM, ATI Radeon HD5450, DeLL 20" Monitor IN2010N
- OS: Ubuntu Mate 16.04. (64Bit)

Notebook:
- Chiligreen Platin SE Notebook
- Dual Boot (LUbuntu14.04 (32Bit) + Windows 7)

Benutzer:
Windows geschädigter Linux-Neuling
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 26.10.2010, 18:51    (Kein Titel) Antworten mit ZitatNach oben

Öhhmmmm... das ist natürlich meine persönliche Meinung/Erfahrung!

Du kannst den "startupmanager" aus der Paketverwaltung installieren...
Nur ACHTUNG, früher, da war er noch nicht in den Repositorys, gabs ne Menge Probleme damit...(Ist aber schon etwa 4 bis 5 Versionen her...)
Weiters kann ich nicht sagen, ob der auch mit Grub2 umgehen kann, es steht davon aber nichts dabei...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Beginner




Geschlecht:
Alter: 40
Anmeldungsdatum: 06.02.2010
Beiträge: 387
Wohnort: Graz


austria.gif

BeitragVerfasst am: 31.10.2010, 18:53    (Kein Titel) Antworten mit ZitatNach oben

Um das Ganze hier abzurunden, hier noch die Informationen, die ich letztens vergessen habe zu posten.

meine /etc/default/grub sieht wie folgt aus
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=13
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


meine /boot/grub/grub.cfg sieht wie folgt aus
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="13"
if [ ${prev_saved_entry} ]; then
  set saved_entry=${prev_saved_entry}
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd1,3)'
search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd1,3)'
search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
set locale_dir=($root)/boot/grub/locale
set lang=de
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
insmod ext2
set root='(hd1,3)'
search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
insmod jpeg
if background_image /boot/grub/wallpaper.jpg ; then
  set color_normal=black/black
  set color_highlight=magenta/black
else
  set menu_color_normal=white/black
  set menu_color_highlight=black/light-gray
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, mit Linux 2.6.32-25-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   linux   /boot/vmlinuz-2.6.32-25-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-25-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-25-generic (Wiederherstellungsmodus)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   echo   'Linux 2.6.32-25-generic wird geladen …'
   linux   /boot/vmlinuz-2.6.32-25-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro single
   echo   'Initiale Ramdisk wird geladen …'
   initrd   /boot/initrd.img-2.6.32-25-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-24-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   linux   /boot/vmlinuz-2.6.32-24-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-24-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-24-generic (Wiederherstellungsmodus)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   echo   'Linux 2.6.32-24-generic wird geladen …'
   linux   /boot/vmlinuz-2.6.32-24-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro single
   echo   'Initiale Ramdisk wird geladen …'
   initrd   /boot/initrd.img-2.6.32-24-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-23-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   linux   /boot/vmlinuz-2.6.32-23-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-23-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-23-generic (Wiederherstellungsmodus)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   echo   'Linux 2.6.32-23-generic wird geladen …'
   linux   /boot/vmlinuz-2.6.32-23-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro single
   echo   'Initiale Ramdisk wird geladen …'
   initrd   /boot/initrd.img-2.6.32-23-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   linux   /boot/vmlinuz-2.6.32-22-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-22-generic (Wiederherstellungsmodus)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   echo   'Linux 2.6.32-22-generic wird geladen …'
   linux   /boot/vmlinuz-2.6.32-22-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro single
   echo   'Initiale Ramdisk wird geladen …'
   initrd   /boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-21-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   linux   /boot/vmlinuz-2.6.32-21-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-21-generic
}
menuentry 'Ubuntu, mit Linux 2.6.32-21-generic (Wiederherstellungsmodus)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   echo   'Linux 2.6.32-21-generic wird geladen …'
   linux   /boot/vmlinuz-2.6.32-21-generic root=UUID=31977c7c-4010-4bb8-8e3c-2a0ef7b70094 ro single
   echo   'Initiale Ramdisk wird geladen …'
   initrd   /boot/initrd.img-2.6.32-21-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   linux16   /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
   insmod ext2
   set root='(hd1,3)'
   search --no-floppy --fs-uuid --set 31977c7c-4010-4bb8-8e3c-2a0ef7b70094
   linux16   /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Home Edition (on /dev/sda1)" {
   insmod ntfs
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set ce2450fc2450e8cb
   drivemap -s (hd0) ${root}
   chainloader +1
}
menuentry "Microsoft Windows XP Professional (on /dev/sdb1)" {
   insmod ntfs
   set root='(hd1,1)'
   search --no-floppy --fs-uuid --set 439cef151e6f4bef
   drivemap -s (hd0) ${root}
   chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###


wenn ich nun wie in http://wiki.ubuntuusers.de/GRUB_2/Konfiguration#Die-Datei-etc-default-grub beschrieben bei GRUB_DEFAULT="xxx" "Microsoft Windows XP Professional (on /dev/sdb1)" eintrage in der /etc/default/grub (also auch mit den beiden Hochkommas), so hat das (nach sudo update-grub) keine Auswirkung auf das GRUB-Menü selbst. (sprich es wir wiederum der erste Eintrag im GRUB-Menü ausgewählt).

Ich dachte es gibt eine Lösung, wie man fix konfigurieren kann, dass die konfigurierte Vor-Auswahl des bevorzugten Menüpunktes in GRUB2 immer mit dem Menüpunkt mitwächst mit dem sie verlinkt ist (unabhängig davon wie viele Kernels noch kommen mögen). Scheinbar ist dem aber nicht der Fall.

@Webbutterfly: Über den Startup-Manager kann man den Menüeintrag im Boot-Menü auch nur statisch festlegen, d.h. bei einem neuen Kernel stimmt dann der Menüpunkt nicht mehr, da ja zwei neue Einträge dazu kommen. Zumindest finde ich keine Einstellungsmöglichkeit wie man das über den Startup-Manager als dynamisch konfigurieren kann.

Never the less, wenns halt ned geht, dann heißt es halt händisch nachziehen - is halt so ... damit kann ich auch leben - wollte eben nur wissen ob man das auch automatisieren kann.

lg
jürgen


Desktop: LXDE Lubuntu and anderer

Version: 14.04 and 16.04

Hardware: Workstation and Notebook

Architektur: 32Bit and 64Bit

_________________
Desktop-Rechner
- DELL Inspiron 570MT, AMD Athlon II X4 630 (2,8GHz, 2MB), 8GB RAM, ATI Radeon HD5450, DeLL 20" Monitor IN2010N
- OS: Ubuntu Mate 16.04. (64Bit)

Notebook:
- Chiligreen Platin SE Notebook
- Dual Boot (LUbuntu14.04 (32Bit) + Windows 7)

Benutzer:
Windows geschädigter Linux-Neuling
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 31.10.2010, 19:02    (Kein Titel) Antworten mit ZitatNach oben

Nach dieser Anleitung sollte es mit dem Startupmanager gehen...
How To Permanently Change The Selected Boot Entry In GRUB2


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
kappa




Geschlecht:
Alter: 47
Anmeldungsdatum: 26.10.2009
Beiträge: 1466
Wohnort: Wien 10


austria.gif

BeitragVerfasst am: 31.10.2010, 19:23    (Kein Titel) Antworten mit ZitatNach oben

Das mit dem startupmanager finde ich gut.
Anderer Ansatz, gleiches Ziel.

Ich tippe nämlich auf einen Syntaxfehler,
doch ich kanns nicht checken, weil Deine gezeigte Konfiguration dem Testszenario nicht entspricht.
(GRUB_DEFAULT=13)

Kannst Du es nach dem startupmanager nochmals herzeigen?

Update:
Habs gerade probiert mit Editieren, Text statt Zahl für GRUB_DEFAULT funkt einwandfrei.


Desktop: Gnome 2.X

Version: 10.04

Hardware: Notebook

Architektur: 32Bit

_________________
Firma: Lenovo T410 10.04 32bit (Intel IGP 1440x900, Intel SSD)
Privat: Lenovo T500 10.04 32bit (Intel IGP 1680x1050, Seagate FDE)
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Beginner




Geschlecht:
Alter: 40
Anmeldungsdatum: 06.02.2010
Beiträge: 387
Wohnort: Graz


austria.gif

BeitragVerfasst am: 01.11.2010, 14:27    (Kein Titel) Antworten mit ZitatNach oben

Hallo,

also wenn ich grub in /etc/default/ wie folgt ändere,

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

#GRUB_DEFAULT=13
GRUB_DEFAULT="Microsoft Windows XP Professional on /dev/sda1"
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""


dann passiert genau das, dass die Auswahl nicht bei Windows ist, sondern ganz oben beim ersten Kernel,

wenn ich wieder GRUB_DEFAULT=13 setze, dann steht die Auswahl am richtigen Menüpunkt.

lg und angenehmen Feiertag ...


Desktop: LXDE Lubuntu and anderer

Version: 14.04 and 16.04

Hardware: Workstation and Notebook

Architektur: 32Bit and 64Bit

_________________
Desktop-Rechner
- DELL Inspiron 570MT, AMD Athlon II X4 630 (2,8GHz, 2MB), 8GB RAM, ATI Radeon HD5450, DeLL 20" Monitor IN2010N
- OS: Ubuntu Mate 16.04. (64Bit)

Notebook:
- Chiligreen Platin SE Notebook
- Dual Boot (LUbuntu14.04 (32Bit) + Windows 7)

Benutzer:
Windows geschädigter Linux-Neuling
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
kappa




Geschlecht:
Alter: 47
Anmeldungsdatum: 26.10.2009
Beiträge: 1466
Wohnort: Wien 10


austria.gif

BeitragVerfasst am: 01.11.2010, 19:07    (Kein Titel) Antworten mit ZitatNach oben

Es ist schon ärgerlich.
Wir haben doch beide explizit darauf hingewiesen (siehe oben),
daß bei Verwendung von Text dieser dann "exakt" zu übernehmen ist.

Warum ist das nicht passiert?

Was ist hier passiert, wo sind die Klammern?
Und warum XP Professional auf sda1, die Titelzeile ist doch mit sdb1.
Diese Zeile hat keinen Tippfehler, sie ist schrecklich entstellt.


Desktop: Gnome 2.X

Version: 10.04

Hardware: Notebook

Architektur: 32Bit

_________________
Firma: Lenovo T410 10.04 32bit (Intel IGP 1440x900, Intel SSD)
Privat: Lenovo T500 10.04 32bit (Intel IGP 1680x1050, Seagate FDE)
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Beginner




Geschlecht:
Alter: 40
Anmeldungsdatum: 06.02.2010
Beiträge: 387
Wohnort: Graz


austria.gif

BeitragVerfasst am: 02.11.2010, 10:42    (Kein Titel) Antworten mit ZitatNach oben

Hallo,

"entstellt" sind die Text aus folgendem Grund

a) die Klammern waren auch mit dabei (on /dev/sdxx) ... beim gleich anschließenden sudo uptdate-grub ist mir aufgefallen, dass dort aber keine Klammern vor bzw. nach dem /dev/sdxx sind. Daher stand der Eintrag dann ohne Klammern dort.

b) bezüglich sdb1 vs sda1 ... das entstand daraus, dass sich sda1 bzw. sdb1 "on the fly" ändert ... Schade ich hätte die Zeilen nach update-grub einfach hier mit rein kopieren sollen.

Vorgehensweise war so:
- editieren von /etc/default/grub
- "Microsoft Windows XP Professional (on /dev/sdb1)" eintragen
- speichern
- sudo update-grub
... oh verdammt bei der Ausgabe von update-grub (found ...) stehen keine Klammern vor und nach dem device ... (Idea -> vielleicht liegt es daran) daher
- editieren von /etc/default/grub
- klammern weg
- speichern
- sudo update-grub
Question die Ausgabe des Befehls von update-grub schreibt XP Professional als sda1 und nicht mehr als sdb1 ... hmmm ... daher
- editieren von /etc/default/grub
- sdb1 auf sda1 ändern
- speichern
- sudo update-grub

Ergebnis immer das Selbige: die Auswahl steht beim ersten Kernel ...

das ganze ist reproduzierbar ... Beweis erfolgt, wenn ich wieder in Reichweite des PCs meiner Eltern bin.

angenehme Woche


Desktop: LXDE Lubuntu and anderer

Version: 14.04 and 16.04

Hardware: Workstation and Notebook

Architektur: 32Bit and 64Bit

_________________
Desktop-Rechner
- DELL Inspiron 570MT, AMD Athlon II X4 630 (2,8GHz, 2MB), 8GB RAM, ATI Radeon HD5450, DeLL 20" Monitor IN2010N
- OS: Ubuntu Mate 16.04. (64Bit)

Notebook:
- Chiligreen Platin SE Notebook
- Dual Boot (LUbuntu14.04 (32Bit) + Windows 7)

Benutzer:
Windows geschädigter Linux-Neuling
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
kappa




Geschlecht:
Alter: 47
Anmeldungsdatum: 26.10.2009
Beiträge: 1466
Wohnort: Wien 10


austria.gif

BeitragVerfasst am: 02.11.2010, 16:23    (Kein Titel) Antworten mit ZitatNach oben

Aha, dann muß der update-grub das alles shreddern.

Das ist ja echt krank.
Probiers mal so:

sudo update-grub
gksudo gedit /boot/grub/grub.cfg


Ziemlich zu Beginn des Files steht ein
set default="...", das entspricht dem GRUB_DEFAULT="...".

Dieses fülle mit dem Inhalt der Titelzeile der entsprechenden menuentry (mit Windows XP Prof) weiter unten.
Am Ende wegspeichern, auch wenn das File nur readonly ist. (ich weiß nicht wie gedit darauf reagiert)
Fertig.

Das ist ein vorläufiger Workaround, weil offensichtlich update-grub buggy ist.
Wie man es sauber lösen kann, das können wir noch diskutieren.

P.S.
Eigentlich müßte der startupmanager in das gleiche Problem laufen,
der verläßt sich wohl auch auf update-grub, was noch zu prüfen ist.
Eine Lösung wäre das disablen des OS Probers in /etc/default/grub und das Anlegen eines Conf Files für die Windows Einträge.
(Oder ein offizieller Patch des update-grub)

P.P.S.
Habs bei mir nochmals getestet: update-grub verschluckt keine Klammern, alles sauber!
Stand: Ubuntu 10.04 32bit


Desktop: Gnome 2.X

Version: 10.04

Hardware: Notebook

Architektur: 32Bit

_________________
Firma: Lenovo T410 10.04 32bit (Intel IGP 1440x900, Intel SSD)
Privat: Lenovo T500 10.04 32bit (Intel IGP 1680x1050, Seagate FDE)
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Beginner




Geschlecht:
Alter: 40
Anmeldungsdatum: 06.02.2010
Beiträge: 387
Wohnort: Graz


austria.gif

BeitragVerfasst am: 08.11.2010, 12:12    (Kein Titel) Antworten mit ZitatNach oben

Hallo,

so die Sache ist nun eingesackt und funktioniert nun auch mit dem Eintrag
GRUB_DEFAULT="Microsoft Windows XP Home Edition (on /dev/sda1)"

was er bei mir offenbar das Problem war ist, dass ich beim ersten mal eintragen einen Fehler gemacht habe und nach Korrektur dieses Fehlers ein abermals ein update-grub machte.

Und - warum auch immer, das weiß ich nicht - beim zweiten Update-grub (unmittelbar hintereinander) wechselt die sdx1 Bezeichnung immer wieder hin und her zwischen den beiden.
"Microsoft Windows XP Home Edition (on /dev/sda1)"
"Microsoft Windows XP Professional (on /dev/sdb1)"

ich werde - nä. Wochenende - meine letzt gültige grub.cfg und meine etc/defautl/grub posten, denn derzeit ist "Microsoft Windows XP Professional" nämlich auf "(on /dev/sda1)" und nicht auf sdb1 wie noch ganz am Anfang des Threads. Und das ohne auch nur hardwaremäßig etwas manipuliert zu haben.


Nur zur Erklärung warum es ein XP Home und ein XP Professional gibt: wie bereits erklärt, ist das mein "Alter" Rechner (MedionPC) bzw. der "neue" Rechner meiner Eltern. Ich hatte damal bereits eine MultiBoot Umgebung mit XP Professional. Ich habe meine Festplatte so belassen und dann einfach die Festplatte aus dem alten Rechner meiner Eltern in den neuen (als Slave gejumped) eingebaut. Daher zwei ...

lg


Desktop: LXDE Lubuntu and anderer

Version: 14.04 and 16.04

Hardware: Workstation and Notebook

Architektur: 32Bit and 64Bit

_________________
Desktop-Rechner
- DELL Inspiron 570MT, AMD Athlon II X4 630 (2,8GHz, 2MB), 8GB RAM, ATI Radeon HD5450, DeLL 20" Monitor IN2010N
- OS: Ubuntu Mate 16.04. (64Bit)

Notebook:
- Chiligreen Platin SE Notebook
- Dual Boot (LUbuntu14.04 (32Bit) + Windows 7)

Benutzer:
Windows geschädigter Linux-Neuling
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Beiträge der letzten Zeit anzeigen:      
Dieses Forum ist gesperrt, du kannst keine Beiträge editieren, schreiben oder beantworten.Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050158317 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1349s (PHP: 74% - SQL: 26%) | SQL queries: 85 | GZIP enabled | Debug off ]