Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 realtek card reader [gelöst]

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 29.10.2012, 08:43    realtek card reader [gelöst] Antworten mit ZitatNach oben

Hallo an alle!
Bitte nach längerer Zeit um Unterstützung zu folgendem Problem:
Ich habe mir ein neues Notebook gekauft (HP 655 B6M65EA) welches an und für sich mit Ubuntu 12.04 sehr gut läuft. Einzige Ausnahme: Der Kartenleser wird nicht erkannt. Ich konnte selbst folgendes ermitteln: Es handelt sich um einen Realtek Cardreader. Einen Treiber hätte ich schon gefunden.
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3&GetDown=false#2
Eine Beschreibung der Installation habe ich auch:

cd rts_pstor
make
sudo make install
sudo depmod


Hier beginnt mein Problem. Beim Ausführen von "make" erhalte ich folgende Fehlermeldung:

helmut@helmut-HP-655:~/Downloads/rts_pstor$ sudo make
[sudo] password for helmut:
sed "s/RTSX_MK_TIME/`date +%y.%m.%d.%H.%M`/" timestamp.in > timestamp.h
cp -f ./define.release ./define.h
make -C /lib/modules/3.2.0-33-generic/build/ SUBDIRS= modules
make[1]: Betrete Verzeichnis '/usr/src/linux-headers-3.2.0-33-generic'
make[2]: *** Keine Regel vorhanden, um das Target »arch/x86/tools/relocs.c«,
  benötigt von »arch/x86/tools/relocs«, zu erstellen.  Schluss.
make[1]: *** [archscripts] Fehler 2
make[1]: Verlasse Verzeichnis '/usr/src/linux-headers-3.2.0-33-generic'
make: *** [default] Fehler 2

Der Befehl sudo tail -f /var/log/syslog zeigt mir, dass die Sd- Karten nicht erkannt werden.
Auch der Eintrag tifm_sd in /etc/modules und sudo modprobe tifm_sd bringen nichts.
An den Karten kann es nicht liegen, da sie mit einem externe Cardreader erkannt werden.
Ich hoffe meine Infos sind ausreichend.
L.G. und danke im Voraus
Helmut


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 29.10.2012, 10:08    (Kein Titel) Antworten mit ZitatNach oben

Hello

Hmmm... ich kann mir nicht vorstellen, dass es am Treiber liegt, der sollte im Kernel vorhanden sein.
Was gibt den
lsusb

aus?


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 29.10.2012, 12:16    lsusb Antworten mit ZitatNach oben

Hallo!
Hier das Ergebnis von lsusb

helmut@helmut-HP-655:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 04f2:b2f4 Chicony Electronics Co., Ltd
Bus 003 Device 002: ID 15ca:00c3 Textech International Ltd. Mini Optical Mouse

L.G. Helmut


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 29.10.2012, 13:01    (Kein Titel) Antworten mit ZitatNach oben

Hmmm...

So wie ich das sehe, wird der Cardreader gar nicht erkannt... sollte eigentlich, auch ohne Treiber, mal aufscheinen.
Bin mir nicht ganz sicher, doch ich denke, der funktioniert nicht...

Kannst du das zB. mit einer Live-CD nochmals prüfen... am besten natürlich mit einer 12.10 (enthält den neuesten Kernel)
Auch die aktuelle Parted-Magic wäre zu empfehlen, Download: http://partedmagic.com/doku.php?id=downloads

Wenn da der Cardreader auch nicht auftaucht, denke ich an einen Defekt...


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 29.10.2012, 14:41    Wo nix is' hat der Kaiser sei' Recht verloren. Antworten mit ZitatNach oben

Laut dem Link ist dieser Card Reader ein PCIe Gerät.

Da hilft kein lsusb, sonder ein lspci.

Seltsam, auf welche Ideen die Gerätehersteller kommen....

Was sagt denn lspci ?

Eventuell hilft da wirklich ein neuer Kernel. Das würde ich ausprobieren.
Ganz sicher kann man den ja auch unter 12.04 installieren.
lg
Paul


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 29.10.2012, 14:52    Noch was ... Antworten mit ZitatNach oben

Mit diesem Card Reader kämpfen andere auch herum:

http://forum.ubuntuusers.de/topic/unbekannter-realtek-sd-kartenleser-einrichten-/


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 29.10.2012, 14:56    lspci Antworten mit ZitatNach oben

Hallo! Hier das Ergebnis von lspci:

helmut@helmut-HP-655:~$ lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 9808
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
00:11.0 SATA controller: Advanced Micro Devices [AMD] Hudson SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices [AMD] Hudson SMBus Controller (rev 14)
00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] Hudson LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] Hudson PCI Bridge (rev 40)
00:15.0 PCI bridge: Advanced Micro Devices [AMD] Device 43a0
00:15.1 PCI bridge: Advanced Micro Devices [AMD] Device 43a1
00:15.3 PCI bridge: Advanced Micro Devices [AMD] Device 43a3
00:16.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:16.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5229 (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
04:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)


Mit Ubuntu 12.10 im Livebetrieb war auch nichts zu machen. Ich glaube, dass Marion recht hat. Ich kann leider keinen Test mit Windows machen. (nicht installiert,XP läuft sowieso nicht Win7 will ich mir nicht besorgen.)

L.G. Helmut


Edit by Admin
Bitte Ausgaben des Terminals in [code] setzen!


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 29.10.2012, 15:00    Cardreader Antworten mit ZitatNach oben

Zitat:
Mit diesem Card Reader kämpfen andere auch herum:

Ich habe das auch schon gelesen und mein Problem ist eben, dass bei der beigefügten Anleitung die im Originalbeitrag genannte Fehlermeldung kommt.
L.G. Helmut


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 29.10.2012, 15:20    Lösung Antworten mit ZitatNach oben

Hallo!
Problem gelöst: Ich habe den Befehl make ohne sudo ausgeführt. Plötzlich lief es und mit checkinstall habe ich mir gleich ein Debianpaket erstellt und damit den Treiber installiert. nach einem Neustart hat es funktioniert. Es wird sogar meine SDHC-Karte erkannt, die mit dem USB-Cardreader nicht erkannt wurde. Das Debianpaket werde ich jetzt 3x sichern. (CD,USB-Stick und Dropbox)
L.G. Helmut

P.S. Bitte Thread auf erledigt setzten. Bin entweder zu dämlich dazu oder ich habe nicht die Berechtigung dazu.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050175902 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1047s (PHP: 74% - SQL: 26%) | SQL queries: 65 | GZIP enabled | Debug off ]