Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Installationsprobleme > bootbarer USB-Stick [?gelöst]

Dieses Forum ist gesperrt, du kannst keine Beiträge editieren, schreiben oder beantworten.Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.
Autor Nachricht
stutz




Geschlecht:
Alter: 37
Anmeldungsdatum: 27.10.2007
Beiträge: 427
Wohnort: Gars


austria.gif

BeitragVerfasst am: 08.06.2008, 22:47    Installationsprobleme > bootbarer USB-Stick [?gelöst] Antworten mit ZitatNach oben

Meine Schwester hat den Laptop aus der jetzigen Hofer-Aktion gekauft.
Beschreibung durch den Hersteller Gericom
Laptop

Eingebaut ist in diesem Laptop eine SATA-Platte. Es hängt nur das CD/DVD -Laufwerk am IDE Kabel, die Platte hängt an SATA Port 1.

Vorgeschichte
Wunsch meiner Schwester: WinXp statt WinVista und ein Linux um einen alten Scanner zu verwenden. (Win ist von nöten, da ein Biblioteks-Programm gebraucht wird. Der Scanner läuft unter Ubuntu 7.10, aber der Scanner braucht einen LTP1 Port, wie ich dieses auf einem Laptop, der nur USB-Anschlüsse hat, lösen werde, ist eine andere Geschichte.)

Problem beschreibung
Beim starten mit alternativer sowie Live-CD 7.10 (MD5SUM -stimmt und ich habe von der CD damals installiert) hängt sich der Vorgang nach dem Starten sofort auf. (Es kommt nacher dieser Ubuntu Schriftzug mit dem Balken darunter, in dem ein oranges Segment durch läuft. Das Segement kommt beim ersten Durchlauf bis zur Hälfte.) Ich habe dann openSuSE 10.3 versucht. Von SuSE weiss ich, dass erkannt wird, dass die Geräte mehr können, aber es wird nicht erkannt, was genau. Deswegen lädt openSuSE, die einfachen "Treiber". Und dann ist Schluss.

Will der Laptop kein Linux aus Prinzip?
Nachdiesem Rückschlag nahm ich Knoppix DVD 5.0, und siehe es war nicht die Schuld von Linux. Aber stutzig machte mich, das Knoppix nicht die Festplatte wie üblich sofort am Destop anzeigte. Mit Parted Magic 1.8 Live CD habe ich die Partion der Festplatte fertig gemacht. (Also Swap und einen Linux-Partion mit ext3 angelegt.) Und es war möglich die Windos Partion zu mounten. (Es wäre sicher unter Knoppix auch gegangen, aber ich bin war zu faul und wollte mich nicht mit dem "mount"-Befehl auseinander setzen, wenn ich noch Parted Magic habe. Ich wollte nur fest stellen, ob Linux überhaupt die Platte sehen kann.)

Lösungsansatz
a) die Parameter bei der Installation gehören geändert, aber auf was ist die Frage.
b) eine OEM - Installation draufspielen, auch hier ist mein Wissensstand NULL.

Nachträglich Editiert
Ich vermute das Problem liegt darin, das Ubunut nicht mit der Kombination von IDE und SATA zurecht kommt, aber ich kann im Bios weder die Platte noch das DVD Laufwert stilllegen.


15.6.2008 Edit by Admin: Titel geändert.


Zuletzt bearbeitet von stutz am 02.10.2008, 18:13, insgesamt 2-mal bearbeitet


Desktop: KDE and XFCE Xubuntu

Version: Andere

Hardware: Workstation and Notebook

Architektur: 64Bit


Zuletzt bearbeitet von stutz am 02.10.2008, 18:13, insgesamt 2-mal bearbeitet
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Gast











BeitragVerfasst am: 09.06.2008, 02:11    (Kein Titel) Antworten mit ZitatNach oben

Hast du irgendwo Linux zur Verfügung ?
USB-Stick mit mindestens 700mb an den Computer stöpseln
sudo su
wget http://speedfreax.bplaced.de/scripts/usbboot.sh
chmod 755 usbboot.sh
./usbboot --help
Und dann von USB-Stick booten und installieren.
Könnte klappen ... Rolling Eyes


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 09.06.2008, 09:00    (Kein Titel) Antworten mit ZitatNach oben

Hello

..es gibt, gleich nach der Auswahl der Sprache mit F1 bis F6 verschiedenste Startparameter... auch für CD-Laufwerke.

Versuche 7.10 zu installieren, ich hatte auch schon Probleme mit den CD-Laufwerken bei 8.04. Ideal wäre ein externes Laufwerk...
Soweit ich weiß, sind diese Hofer-PC leider immer sehr problematische Geräte... meist mit eigener Hardware und die ist nicht immer kompatibel (irgendwo muss der günstige Preis ja herkommen). Man kann auch das System nur mit der beigelegten CD wieder recovern... nicht neu installieren, diese ist speziell für die Hardware angepasst... eine normale Windosen-CD (Installation) macht auch hier Troubles.

Die OEM-Version von Ubuntu ist prinzipielle nicht anders als die normale... man kann dann nur den bei der Installation angelegten User OEM löschen (mit einem Befehl) und beim Neustart wird dann nach den persönlichen Daten gefragt und er neue Benutzer hat ein personalifiziertes System... wie bei allen OEM Installationen.

Marion

Edit: Es kann auch ganz ein simpler Grund sein... schaue mal (mit einer Live-CD) nach wie viele Partitionen schon vorhanden sind... wenn es mehr als zwei Primäre oder Container für eine Erweiterte sinf, kann es nicht funktionieren.
Ubuntu legt zumindest eine Primäre und eine Erweiterte an... und es können nur 4 Primäre / Container für Erweiterte angelegt werden.
Achtung, wenn da eine DOS-Part. vorhanden ist (für Recovery), siehst du diese unter Windose nicht.. dh. Live-CD und
sudo fdisk -l ist am sichersten.... gParted unter Knoppix.


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
stutz




Geschlecht:
Alter: 37
Anmeldungsdatum: 27.10.2007
Beiträge: 427
Wohnort: Gars


austria.gif

BeitragVerfasst am: 09.06.2008, 13:20    (Kein Titel) Antworten mit ZitatNach oben

@Re-Exess
Habe den Laptop bis zum Wochenende nicht zur Verfügung, deshalb kann ich erst am Wochenende, dass mit USB-Stick testen.

@Webbutterfly
Im Lieferumfang war - Gott Sei Gedankt - eine CD mit den Treibern für das Motherboard für Vista und Xp. Deswegen hatte ich keine Hemmungen, die ganze Festplatte zu lösen und alle vorhanden Partiotionen. (Falls es eine Recoery gewesen wäre, wäre sei für Vista gewesen, und wäre Sinnloss bei Xp.)
« Webbutterfly » hat folgendes geschrieben:
wenn da eine DOS-Part. vorhanden ist (für Recovery), siehst du diese unter Windose nicht

Ich habe mit Parted Magic 1.8 Live CD (Programm gParted) die Partion der Festplatte fertig gemacht, wenn was da war, ist es nun weg.


Desktop: KDE and XFCE Xubuntu

Version: Andere

Hardware: Workstation and Notebook

Architektur: 64Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
stutz




Geschlecht:
Alter: 37
Anmeldungsdatum: 27.10.2007
Beiträge: 427
Wohnort: Gars


austria.gif

BeitragVerfasst am: 14.06.2008, 18:40    (Kein Titel) Antworten mit ZitatNach oben

« Re-Exess » hat folgendes geschrieben:
Hast du irgendwo Linux zur Verfügung ?
USB-Stick mit mindestens 700mb an den Computer stöpseln
sudo su
wget http://speedfreax.bplaced.de/scripts/usbboot.sh
chmod 755 usbboot.sh
./usbboot --help
Und dann von USB-Stick booten und installieren.
Könnte klappen ... Rolling Eyes


Habe das nun ausbrobiert mit folgendem Ergebnis

Ist das erste Mal durch gelaufen bis zu dem Punkt an dem Befehl syslinux vor kommt, habe dieses Paket installiert.

Seit dem beendet er es hier.
-> Change Partition Table on /dev/sdb
Change Partition table on /dev/sdb failed

Unerwünschter Neben Wirkung habe einen USB-Stick runiert. Aus 1 GB sind 8 MBit geworden.


Desktop: KDE and XFCE Xubuntu

Version: Andere

Hardware: Workstation and Notebook

Architektur: 64Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Gast











BeitragVerfasst am: 14.06.2008, 18:44    (Kein Titel) Antworten mit ZitatNach oben

Neu partitionieren - dann geht der Stick wieder.
sudo gparted


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
stutz




Geschlecht:
Alter: 37
Anmeldungsdatum: 27.10.2007
Beiträge: 427
Wohnort: Gars


austria.gif

BeitragVerfasst am: 14.06.2008, 19:33    (Kein Titel) Antworten mit ZitatNach oben

Leider ist dieses Problem nicht so leicht zu lösen mit gparted auch gpart findet nichts mehr


Desktop: KDE and XFCE Xubuntu

Version: Andere

Hardware: Workstation and Notebook

Architektur: 64Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Gast











BeitragVerfasst am: 14.06.2008, 19:38    (Kein Titel) Antworten mit ZitatNach oben

sudo fdisk -l
sudo cfdisk /dev/sdX


Zuletzt bearbeitet von Gast am 14.06.2008, 20:13, insgesamt einmal bearbeitet


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit


Zuletzt bearbeitet von Gast am 14.06.2008, 20:13, insgesamt einmal bearbeitet
Online    
stutz




Geschlecht:
Alter: 37
Anmeldungsdatum: 27.10.2007
Beiträge: 427
Wohnort: Gars


austria.gif

BeitragVerfasst am: 14.06.2008, 20:05    (Kein Titel) Antworten mit ZitatNach oben

fdisk -l
Disk /dev/sdb: 8 MB, 8388608 bytes
1 heads, 16 sectors/track, 1024 cylinders
Units = cylinders of 16 * 512 = 8192 bytes
Disk identifier: 0x00000000

Disk /dev/sdb doesn't contain a valid partition table


Desktop: KDE and XFCE Xubuntu

Version: Andere

Hardware: Workstation and Notebook

Architektur: 64Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Gast











BeitragVerfasst am: 14.06.2008, 20:12    (Kein Titel) Antworten mit ZitatNach oben

sudo cfdisk -z /dev/sdb

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
stutz




Geschlecht:
Alter: 37
Anmeldungsdatum: 27.10.2007
Beiträge: 427
Wohnort: Gars


austria.gif

BeitragVerfasst am: 14.06.2008, 20:23    (Kein Titel) Antworten mit ZitatNach oben

Ja, das habe ich gemacht soweit bin ich auch gekommen, aber ich weiss nicht weiter. Partion löschen, oder erstellen muss. Muss ich irgendwas in die Partion Table reinschreiben?
Ich muss die Sektoren erhöhen, vermute ich. Auf welche Zahl ist die Frage? Oder bin ich komplett falsch?


Desktop: KDE and XFCE Xubuntu

Version: Andere

Hardware: Workstation and Notebook

Architektur: 64Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Gast











BeitragVerfasst am: 14.06.2008, 22:40    (Kein Titel) Antworten mit ZitatNach oben

Einfach eine Partition erstellen - das wars

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
stutz




Geschlecht:
Alter: 37
Anmeldungsdatum: 27.10.2007
Beiträge: 427
Wohnort: Gars


austria.gif

BeitragVerfasst am: 14.06.2008, 23:57    (Kein Titel) Antworten mit ZitatNach oben

Was hilft es mir eine 8 MBit grosse Partion zu haben?


Desktop: KDE and XFCE Xubuntu

Version: Andere

Hardware: Workstation and Notebook

Architektur: 64Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Gast











BeitragVerfasst am: 15.06.2008, 11:15    (Kein Titel) Antworten mit ZitatNach oben

sudo dd if=/dev/zero of=/dev/sdb (das dauert ne weile und endet in einer Fehlermeldung)
sudo cfdisk -z /dev/sdb

Wenn das auch nicht hinhaut ist der Stick wirklich hin.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Dieses Forum ist gesperrt, du kannst keine Beiträge editieren, schreiben oder beantworten.Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050156910 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 2.6112s (PHP: 99% - SQL: 1%) | SQL queries: 90 | GZIP enabled | Debug off ]