Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Huawei E510 wird nicht als USB-Modem erkannt

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 13.09.2008, 17:26    (Kein Titel) Antworten mit ZitatNach oben

Hello

...in deinem geposteten Protokoll sehe ich nur eines was mich irritiert:
Query sends the following mesage: 'ATD*99***1#
wo kommt das her?
Wie sieht dein Profileintrag in umtsmon aus?


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 14.09.2008, 01:36    (Kein Titel) Antworten mit ZitatNach oben

Hi,
ich denke diese message:ATD*99***1# kommt von meinem Provider, ich bin bei o2.

Mein Profil ist:

einloggen:
APN => suro2
Name => o2
Passwort => o2

Erweiterte PPP Einstellungen:
haken bei... keine Autorisierung, Ersetze Default Route, Default Route einstellen

wie kann ich UMTSmon komplett entfernen, damit ich es von neu installiere. vielleicht hab ich dann mehr glück. hat ja auch alles funktioniert, nur als ich mich mal mit gnome-ppp verbinden wollte und es nicht geklappt hat wollte auch UMTSmon nicht mehr.
woran kann das liegen?
Danke im voraus für die Hilfe!!

Gruß
Damir

OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 14.09.2008, 10:12    (Kein Titel) Antworten mit ZitatNach oben

Hello

..du kannst den Ordner .umtsmon in deinem home leeren... ein deinstallieren ist nicht notwendig...
Sind mit ls -l /dev/ttyU* die USB vorhanden?

Die APN für O2 sollte "internet" sein

PS: Gnome-PPP und KPPP kann mit einer PIN nicht so einfach umgehen, hier ist es notwendig die wvdial zu bearbeiten, wenn die PIN nicht deaktiviert wurde...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 14.09.2008, 13:27    (Kein Titel) Antworten mit ZitatNach oben

hallo,
also ich habs jetzt nochmal gelöscht und bekomme eine Fehlermeldung bei PPP stderr:

/usr/sbin/pppd: using the noauth option requires root privilege

das mit internet steht jetzt seit der installation automatisch drin.
was bedeutet jetzt dieser neue Fehler?

OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 15.09.2008, 09:16    (Kein Titel) Antworten mit ZitatNach oben

Hi,
hab vergessen noch die Frage zu beantworten, also ls -l /dev/ttyU* ist vorhanden.
Alles bis auf das einwählen läuft ohne Probleme,das mit der root Fehlermeldung ist nicht mehr da weil ich mit sudo umtsmon gestartet hab.Aber weiterhin bestehen Probleme bei "Aktiviere PPP" also bei der Einwahl.
Wie müsste denn wvdial konfiguriert werden für den o2 Provider?
Vielleicht wäre es eine Lösung ein anderes Programm unter Ubuntu zu benutzen?
Habs jetzt unter Vista nochmal ausprobiert, es klappt. Also am Gerät liegt der Fehler nicht.

OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 15.09.2008, 20:39    (Kein Titel) Antworten mit ZitatNach oben

@Webbutterlfy
was kann ich noch probieren, wenn es mal funktioniert hat sollte es doch irgendwie machbar sein, oder?
mir ist aufgefallen, als ich mit gnome-ppp es konfigurieren wollte und auf erkennen geklickt habe, dass er /dev/ttyUSB2 als schnittstelle für das Modem gewählt hat. kann es sein das dadurch prebleme auftauchen? wie könnte ich auf /dev/ttyUSB0 umschalten?

OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 15.09.2008, 21:31    (Kein Titel) Antworten mit ZitatNach oben

Hello

Ich kann dir nur empfehlen, unser umtsmon-Script nochmals down zu laden und zu installieren...
Würde meinen die Onlineinstallation...

Umtsmon auf keinen Fall als Sudo starten... Hier solltest du den Ordner /root/.umtsmon löschen (wenn vorhanden).

Marion

PS: Gnome-ppp kann da zwar keine Rolle spielen, doch deinstalliere es trotzdem... "vollständig entfernen"

EDIT:22:50
bevor du das alles machst....
führst du auch
sudo modprobe usbserial vendor=0x12d1 product=0x1411

jedes mal durch... sonst kann es nicht funktionieren!
Wenns klappt, kannst du die Zeile
usbserial vendor=0x12d1 product=0x1411
in die /etc/modules am Ende eintragen, dann ist es nicht mehr notwendig.


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 15.09.2008, 23:04    (Kein Titel) Antworten mit ZitatNach oben

hi,
danke für deine Antwort, also das Problem liegt nicht in dem befehl:

sudo modprobe usbserial vendor=0x12d1 product=0x1411


das übernimmt er problemlos, auch

ls -l /dev/ttyUSB*


macht eine Ausgabe. Nur wenn ich mich verbinden will, dann zeigt er mir die Schnittstelle /ttyUSB2 an.
Auf dieser http://www.fedorawiki.de/index.php/Huawei_E220_GPRS_/_UMTS_/_HSDPA_USB_Modem Seite und noch auf anderen habe ich gelesen das es unterschiede in den Schnittstellen /dev/ttyUSB0/1/2 gibt.
Jetzt würde ich zu der /dev/ttyUSB0 schnittstelle switchen, dazu brauche ich ein Programm oder die Befehle.
Kannst du mir dabei helfen?

OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 15.09.2008, 23:08    (Kein Titel) Antworten mit ZitatNach oben

...mach es !

Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 15.09.2008, 23:16    (Kein Titel) Antworten mit ZitatNach oben

weisst du zufällig wie ich am leichtesten diesen Schnittstellen wechsel von ttyUSB2 -> ttyUSB0 machen kann?
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 16.09.2008, 08:33    (Kein Titel) Antworten mit ZitatNach oben

Diskutierst du nur mit mir oder machst was ich dir schreibe? Evil or Very Mad
..gibst du sudo modprobe usbserial vendor=0x12d1 product=0x1411 ein? Hast du home/.umtsmon gelöscht?
Das möchte ich wissen.

Alle Möglichkeiten sind im Thema schon angegeben...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 16.09.2008, 10:07    (Kein Titel) Antworten mit ZitatNach oben

« hr_damir » hat folgendes geschrieben:
hi,
danke für deine Antwort, also das Problem liegt nicht in dem befehl:

sudo modprobe usbserial vendor=0x12d1 product=0x1411


das übernimmt er problemlos, auch

ls -l /dev/ttyUSB*


macht eine Ausgabe. Nur wenn ich mich verbinden will, dann zeigt er mir die Schnittstelle /ttyUSB2 an.
Auf dieser http://www.fedorawiki.de/index.php/Huawei_E220_GPRS_/_UMTS_/_HSDPA_USB_Modem Seite und noch auf anderen habe ich gelesen das es unterschiede in den Schnittstellen /dev/ttyUSB0/1/2 gibt.
Jetzt würde ich zu der /dev/ttyUSB0 schnittstelle switchen, dazu brauche ich ein Programm oder die Befehle.
Kannst du mir dabei helfen?

Hi,
habe schon in diesem Thread geschrieben das der sudo modprobe... geklappt hat wie auch der ls -l /dev/ttyUSB* zeigt was an.
Dieser Ordner -> home/.umtsmon ist bei mir nicht vorhanden
In diesem Link -> http://www.fedorawiki.de/index.php/Huawei_E220_GPRS_/_UMTS_/_HSDPA_USB_Modem wird geschrieben, das es wichtig ist die Schnittstelle /dev/ttyUSB0 zu bekommen.Deshalb vermute ich das dort der Fehler liegt!?

OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 16.09.2008, 10:26    (Kein Titel) Antworten mit ZitatNach oben

Zitat:
Dieser Ordner -> home/.umtsmon ist bei mir nicht vorhanden
..das kann ich mir nicht vorstellen..
"versteckte Dateien Anzeigen" aktiviert !

und genau das steht auch drinnen:
[device]
ATPortName=/dev/ttyUSB2
DeviceType=0x5e21a700
PPPPortName=/dev/ttyUSB0


Wenn du genau das so machst wie es funktioniert hat... siehe Anfang des Themas, muss es auch wieder funktionieren.

Sorry, es kann nicht sein, dass es mal geht und dann nicht, wiederhole ganz einfach das Ganze nochmals...

Booten mit eingesteckten Modem.
sudo usbserial....
Laufwerk auswerfen
Test: ls - l /dev/ttyUSB* auch lsusb
Umtsmon starten....


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 16.09.2008, 17:24    (Kein Titel) Antworten mit ZitatNach oben

hi,
also ich hab die ganzen Schritte gemacht, nachdem ich alles gelöscht habe.
Nach der neuen Installation hab auch den Ordner /home/.umtsmon gefunden und gelöscht, einen Neustart gemacht mit eingestecktem Umts-Modem.
Die Befehle ausgeführt und dann kommt folgende Fehlermeldung schon wieder:

PPP Fehler Logs => PPP stdout

Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB2
LCP: timeout sending Config-Requests
Connection terminated.
Receive serial link is not 8-bit clean:
Problem: all had bit 7 set to 0
Modem hangup

Ich würde gern dieses /dev/ttyUSB2 umändern, sodass ich /dev/ttyUSB0 bekomme. Könnte sein das dann die Fehlermeldung weg ist....??

OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050158686 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1202s (PHP: 69% - SQL: 31%) | SQL queries: 90 | GZIP enabled | Debug off ]