Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Huawei E510 wird nicht als USB-Modem erkannt

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 16.09.2008, 17:33    (Kein Titel) Antworten mit ZitatNach oben

..nun du kannst es in der home/.umtsmon/umtsmonrc
versuchen zu ändern...


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
hr_damir






Anmeldungsdatum: 09.09.2008
Beiträge: 20
Wohnort: koblenz


blank.gif

BeitragVerfasst am: 16.09.2008, 22:24    (Kein Titel) Antworten mit ZitatNach oben

hi,
also das Problem ist gelöst. in dieser Datei /home/.umtsmon/umtsmonrc stand:


[device]
ATPortName=/dev/ttyUSB2
DeviceType=0x5e21a700
PPPPortName=/dev/ttyUSB2


geändert in:


[device]
ATPortName=/dev/ttyUSB2
DeviceType=0x5e21a700
PPPPortName=/dev/ttyUSB0


Also das Problem war das für PPPPortName die verkehrte Schnittstelle zugewiesen war. Diese Schnittstelle /dev/ttyUSB2 ist nur für den monitoring modus und nicht für die Verbindung zum Internet gedacht.
Großen Dank an Webbutterfly!!!! wink

OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
tux_johny




Geschlecht:
Alter: 43
Anmeldungsdatum: 15.10.2008
Beiträge: 12
Wohnort: Tuxhausen


austria.gif

BeitragVerfasst am: 23.10.2008, 21:42    (Kein Titel) Antworten mit ZitatNach oben

Hallo Community!

Ich habe ein Huawei E510, aber es funktioniert noch nicht richtig.
Umtsmon gibt folgende Fehlermeldung aus:


john@johnylinlap:~$ umtsmon
umtsmon version 0.8 .
installing GUI SIGABRT handler
##P1 t=914: aLocale '(null)' denied
Could not write to serial device: Resource temporarily unavailable
##P1 t=914: *** CRITICAL ERROR: Kann nicht (mehr) auf das Ger�t schreiben


  *** umtsmon version 0.8 closed due to an unrecoverable program error.
  *** Please e-mail all of the above output to umtsmon-develop@lists.sourceforge.net,
  *** Or go to the umtsmon website and file a bug.


##P1 t=916: Critical Popup - application will halt
Mutex destroy failure: Device or resource busy
john@johnylinlap:~$


Ich habe die Anleitung für UMTS Modems befolgt und das E510 wird auch nicht mehr automatisch gemounted, seit ich das Modul "usb_serial" der blacklist zugeführt habe.

lsusb gibt folgendes aus:

john@johnylinlap:~$ lsusb
Bus 004 Device 012: ID 12d1:1411 Huawei Technologies Co., Ltd.
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 003: ID 046d:c00c Logitech, Inc. Optical Wheel Mouse
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
john@johnylinlap:~$


Ich habe auch das Modul "usbserial" mit oben genannten Parametern in der /etc/modules.

Ein paar Sekunden nach dem Anstecken des Modems habe ich es auch als character device:


john@johnylinlap:~$ ls -l /dev/ttyU*
crw-rw---- 1 root dialout 188, 0 2008-10-23 20:48 /dev/ttyUSB0
john@johnylinlap:~$


Aber es scheint "beschäftigt" zu sein.
Was kann ich noch tun?

Danke für eure Hilfe.

tux_johny


Desktop: KDE

Version: 8.10

_________________
There are only IO reasons for bits:

I and O
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 23.10.2008, 22:01    (Kein Titel) Antworten mit ZitatNach oben

Hello

...also ich würde das Modul usbserial nicht in die Blacklist eintragen...
Dir fehlt /dev/ttyUSB1 & /dev/ttyUSB2...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
tux_johny




Geschlecht:
Alter: 43
Anmeldungsdatum: 15.10.2008
Beiträge: 12
Wohnort: Tuxhausen


austria.gif

BeitragVerfasst am: 24.10.2008, 14:29    (Kein Titel) Antworten mit ZitatNach oben

Hello!
Sorry, mein Fehler. Ich habe natürlich "usb_storage" in der blacklist, nicht "serial". Warum kein /dev/ttyUSB1 und 2 angelegt wird, weiss ich nicht.
johny


Desktop: KDE

Version: 8.10

_________________
There are only IO reasons for bits:

I and O
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
tux_johny




Geschlecht:
Alter: 43
Anmeldungsdatum: 15.10.2008
Beiträge: 12
Wohnort: Tuxhausen


austria.gif

BeitragVerfasst am: 24.10.2008, 16:15    (Kein Titel) Antworten mit ZitatNach oben

Hallo!

Wie kann ich /dev/ttyUSB1 und 2 erzeugen lassen, bzw. warum wird es nicht erzeugt, wenn ttyUSB0 erstellt wird? Ich habe das Modem übrigens in Windoof getestet, da es hat funktioniert.
Noch eine Info zu meinem System:
john@johnylinlap:~$ uname -a
Linux johnylinlap 2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux
john@johnylinlap:~$


mfg

tux_johny


Desktop: KDE

Version: 8.10

_________________
There are only IO reasons for bits:

I and O
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 24.10.2008, 18:37    (Kein Titel) Antworten mit ZitatNach oben

Hello

..ich habe jetzt nochmals gestöbert...
Das Ding ist ja auch ein DVB-T-Stick.... daher wird sich das DVB-T Modul mit vendor=0x1411 einhängen.
Soweit ich heraus bekommen habe ist die Richtige Vendor ID 1003...
Die Frage ist nur ob du es ändern kannst bzw. die Falsche zu überschreiben ... vendor=0x1003

Es sind halt nicht alle Modems für Ubuntu-Linux geeignet... also Vorsicht beim Kauf und eines nehmen, dass schon getestet wurde.
...und das es unter Windose funktioniert, sagt leider nichts aus. Die Hersteller sind ganz einfach auf Windose fixiert und es gibt da keine Normen für USB, auch wenn es wenige wissen. Würden die Kernelentwickler alle properitären USB-Schnittstellen raus werfen (was schon angesprochen wurde), so würden 50% aller USB-Geräte nicht funktionieren.

PS: Für das ZTE MF628 gibt es in 8.10 auch noch keine Möglichkeit, dass das Modem erkannt wird... Da läuft ein Bugreport auf Launchpad...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
tux_johny




Geschlecht:
Alter: 43
Anmeldungsdatum: 15.10.2008
Beiträge: 12
Wohnort: Tuxhausen


austria.gif

BeitragVerfasst am: 25.10.2008, 07:26    (Kein Titel) Antworten mit ZitatNach oben

Hello auch!

Ja, das ist auch ein DVB-T-Stick. Ich versuch es mal mit der Vendor ID 1003.
Ja, ich habe vorher gegoogelt, ob der E510 unter Linux läuft. Sieht ja nicht so schlecht aus, bei den meisten anderen Linux usern...
Doch, das sagt eine Menge aus, wenn das Teil unter Windoof funktioniert: Es funktioniert. Könnte ja auch defekt sein. Stichwort physical layer.
Nein, die Kernel Entwickler sollten die proprietären USB-Schnittstellen nicht rauswerfen.
Ich werde allfällige Ergebnisse posten. Notfalls muss ich mit makedev rumpfuschen...
Eine Frage hab ich noch: Soll ich die PIN Abfrage deaktivieren?

mfg

tux_johny


Desktop: KDE

Version: 8.10

_________________
There are only IO reasons for bits:

I and O
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
tux_johny




Geschlecht:
Alter: 43
Anmeldungsdatum: 15.10.2008
Beiträge: 12
Wohnort: Tuxhausen


austria.gif

BeitragVerfasst am: 26.10.2008, 10:52    (Kein Titel) Antworten mit ZitatNach oben

Hello again!

Ich habe die Vendor ID auf 1003 gestellt, hat aber nichts geholfen. Auch ein "makedev usb" ändert nicht viel. Es legt zwar jede Menge ttyUSB* an (14 oder 15) nämlich unter /dev/.static/dev/. Aber diese devices sind auch nicht kooperativer. still "busy".
Die PIN Abfrage habe ich ausgeschalten, hat nichts geändert.
Ich werde umtsmon entfernen und neu installieren. Leider muss ich dafür die offline version verwenden. Vielleicht hab ich irgendetwas übersehen.

mfg

tux_johny


Desktop: KDE

Version: 8.10

_________________
There are only IO reasons for bits:

I and O
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 26.10.2008, 11:20    (Kein Titel) Antworten mit ZitatNach oben

...es liegt sicher nicht an umtsmon...

Du kannst es mit dem Networkmanager 0.7 versuchen... denke aber es wird das selbe Problem sein...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
tux_johny




Geschlecht:
Alter: 43
Anmeldungsdatum: 15.10.2008
Beiträge: 12
Wohnort: Tuxhausen


austria.gif

BeitragVerfasst am: 27.10.2008, 11:57    (Kein Titel) Antworten mit ZitatNach oben

Lieber Schmetterling!

Ja, da bin ich mir auch sicher, das umtsmon nicht schuld ist. Umtsmon ist ein tolles tool! Ich hab es ja auch schon ausprobiert, bei einem Freund mit einem e220. Haben will. wink
Mein Problem sind eher irgendwelchen verkorksten udev Regeln. Das Modem wurde nach der Neuinstallation wieder automatisch als block device gemounted. Problem: Die Regel 75 erstellt Regeln für (neue) block devices, die in die Regel 70 geschrieben werden. Meine Lösung: Bestehende Einträge für das umts Teil in Regel 70 entfernen. Eine neue 99er Regel schreiben, mit dem Inhalt: Modem als block device ingorieren.
Jetzt wird das gute Stück aber auch nicht mehr als character device /dev/ttyUSB0 eingehängt. Auch nicht nach einem modprobe usbserial (...).
Ich werde wieder mit makedev drüberbügeln und mal sehen, ob jetzt was hilft.
Networkmanager kann ich nicht ausprobieren, da ich es nicht installieren kann ohne internetz auf meinem geliebten Linux. [heul] Nutzt aber wahrscheinlich eh nix. Ich halte Euch am laufenden, falls interessiert... Und falls jemand eine Idee hat, wie man udev richtig bedient: Bitte sehr. Auch haben will.

Mit freundlichen Gruessen

tux_johny


Desktop: KDE

Version: 8.10

_________________
There are only IO reasons for bits:

I and O
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
tux_johny




Geschlecht:
Alter: 43
Anmeldungsdatum: 15.10.2008
Beiträge: 12
Wohnort: Tuxhausen


austria.gif

BeitragVerfasst am: 12.11.2008, 17:38    (Kein Titel) Antworten mit ZitatNach oben

Problem gelöst!

Ich habe Muhbuntu 8.10 installiert und auf das jungfräuliche System mittels offlinepaket umtsmon installiert. Kein (zusätzliches) Bearbeiten der udev rules war nötig, kein blacklist Eintrag und auch kein unmounten des E510! Die ttyUSB Einträge 0 bis 4 werden automatisch erzeugt und können auch gleich verwendet werden. umtsmon muss ich mit der option "-s /dev/ttyUSB1,/dev/ttyUSB0" von der Konsole aus aufrufen, aber das huwaei geht.

Danke und Bye.

tux_johny


Desktop: KDE

Version: 8.10

_________________
There are only IO reasons for bits:

I and O
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 62
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 12.11.2008, 17:42    (Kein Titel) Antworten mit ZitatNach oben

...in 8.10 ist umtsmon nicht mehr notwendig!
Da funktionier alles über den Networkmanager....

Ein Highlight von 8.10 Very Happy

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
tux_johny




Geschlecht:
Alter: 43
Anmeldungsdatum: 15.10.2008
Beiträge: 12
Wohnort: Tuxhausen


austria.gif

BeitragVerfasst am: 30.03.2009, 10:59    (Kein Titel) Antworten mit ZitatNach oben

...aber leider funktioniert das huawei e510 weiterhin nur mit umtsmon, und nicht mit dem (K)Networkmanager. Vielleicht unter (K)Ubuntu 9.04 dann, aber bis dahin bin ich froh, dass es umtsmon gibt. Ich habe das uebrigens auf 2 verschiedenen Rechnern getestet.
Greetings :-)

tux_johny


Desktop: KDE

Version: 8.10

_________________
There are only IO reasons for bits:

I and O
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050156745 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1208s (PHP: 67% - SQL: 33%) | SQL queries: 90 | GZIP enabled | Debug off ]