Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 drei.at + umtsmon/gnome-PPP/networkmanager

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 25.11.2008, 19:13    drei.at + umtsmon/gnome-PPP/networkmanager Antworten mit ZitatNach oben

Hi leute!

specs mal vorweg:
Ubuntu 8.10
Huawei E620 USB Modem (zumindest meldet das lsusb - auf der Packung steht aber E169G)

installiert sind:
umtsmon-0.9
networkmanager (das standart-ding von ubuntu 8.10 halt...)
gnome-PPP

ich bekomm mit keinem der drei was zusammen.
umtsmon:
kann die Signalstärke anzeigen, kann SMS senden (daher sag ich mal, das Modem wird erkannt), beim connect sagt er "Receive serial link is not 8-bit clean: Problem all had bit 7 set to 0"
dazu gibts in einem anderen thread einen hinweis auf google - was sehr viel hilft... bzw mir halt nicht.

gnome-PPP:
Bad init string

konfiguration kann ich jetzt nicht posten, werd ich nachholen, falls das interessant sein sollte.

networkmanager:
der ist interessant.

richtig konfiguriert schafft er eine Verbindung - das Problem ist dann aber, dass ich nur auf die standart-drei-fehlermeldungs-seiten komme, also http://mobile.drei.at/333_TopCo/?nocredit=true - das sagt "Lieber 3Kunde! Dieses Service ist derzeit nicht verfügbar."
Ich vermute mal, dass das an den PPP-Einstellungen liegt - ich bin aber bei der Installation immer streng nach den hier im forum verfügbaren howtos vorgegangen.

Weitere Informationen:
- unter Windows funktionierts einwandfrei
- mit umtsmon-0.8 hat es bereits mal funktioniert - bei der allerersten installation von umtsmon-0.8 - seitdem nie mehr wieder, egal ob mit umtsmon-0.8 oder mit umtsmon-0.9
- ich hab ein netbook, neuinstallation von ubuntu ist grausam, daher will ichs vermeiden.
- am liebsten wär mir wenn der networkmanager funktioniert - der ist um einiges praktischer als alles andere

anyone any ideas?


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 25.11.2008, 19:43    (Kein Titel) Antworten mit ZitatNach oben

Hello

Frage, hast du umtsmon-0.8 mit unserem Script installiert? Dann musst du die Dateien
/sbin/huaweiAktBbo
und
/etc/udev/rules.d/52-huawei-e220.rules
löschen! Die sind nicht mehr notwendig und machen Probleme.
Unbedingt nachher ein reboot...

Des weiteren musst du im Networkmanager die Eintragungen anpassen:
Nummer: *99#
Benutzername: drei.at
Passwort: drei.at
APN: drei.at
Rest bleibt...
(Ich kann es aber leider nicht testen...)
Als DNS kannst du noch
213.94.78.16 und 213.94.78.17
eintragen.

Mit Umtsmon musst du ein Profil mit obigen Daten anlegen.

Marion

PS: Gnome-PPP lass weg, die Einwahl damit ist nicht mehr aktuell...


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 25.11.2008, 21:07    (Kein Titel) Antworten mit ZitatNach oben

« Webbutterfly » hat folgendes geschrieben:

Des weiteren musst du im Networkmanager die Eintragungen anpassen:
Nummer: *99#
Benutzername: drei.at
Passwort: drei.at
APN: drei.at


gelse@fliegenmini:~$ ls -l /sbin/huawei*
ls: Zugriff auf /sbin/huawei* nicht möglich: No such file or directory
gelse@fliegenmini:~$ ls -l /etc/udev/rules.d/52*
ls: Zugriff auf /etc/udev/rules.d/52* nicht möglich: No such file or directory


rest: been there, done that, did not work.

@attachments - ich denke, die einstellungen sind korrekt.


Zuletzt bearbeitet von Gast am 25.11.2008, 21:49, insgesamt 3-mal bearbeitet


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit


Zuletzt bearbeitet von Gast am 25.11.2008, 21:49, insgesamt 3-mal bearbeitet
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 25.11.2008, 21:39    (Kein Titel) Antworten mit ZitatNach oben

Hello

Es war ja nur eine Frage wegen umtsmom 0.8, wenn du sie nicht hast, ist es OK...
nur wenn ich nicht Frage, gibt es Probleme damit und ich weiß nicht ob es daran liegt.

Da du ja eine Verbindung bekommst, kann es nur an den Zugangsdaten liegen....
Vielleicht sind meine auch nicht richtig..


Marion

EDIT: schau mal da nach: Welche Einstellungen für drei @ Ubuntu 8.10 NetworkManager


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 25.11.2008, 21:51    (Kein Titel) Antworten mit ZitatNach oben

natürlich ebenfalls schon durchgegangen, und auch das xml ausgetauscht.
hat nichts gebracht.

ich würd ja vielleicht aufgeben - aber das fiese ist, dass es ja bereits mal funktioniert hat!

gelse@fliegenmini:~$ cat /etc/wvdial.conf
[Dialer Defaults]
Init1 = ATZ
Init2 = ATS0=0
Init3 = AT+CGATT=0
Init4 = AT+CGQREQ=1,0,0,0,0,0
Init5 = AT+CGQMIN=1,0,0,0,0,0
Init6 = AT+CGDCONT=1,"IP","drei.at","0.0.0.0",0,0
Init7 = ATE1V1&D2
Init8 = AT+IFC=2,2
Stupid Mode = 1
SetVolume = 0

ISDN = 0
Phone = *99#

Modem Type = USB Modem
Modem = /dev/ttyUSB2
Baud = 460800
FlowControl = NOFLOW
Dial Command = ATDT


edit: hab grad umtsmon nochmal ausprobiert, mit "drei.at" statt "drei" als username/password.
siehe da, er kann sich auf einmal verbinden.
das problem ist jetzt aber dasselbe wie mit dem networkmanager, jeder browser request geht auf die gleiche seite (siehe attachment)


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 25.11.2008, 22:08    (Kein Titel) Antworten mit ZitatNach oben

ich hab dazu folgendes gefunden:
http://umtslink.at/3g-forum/archive/index.php/t-28482.html

Aber irgendwie glaub ich nicht, dass dem so ist - ich hab ein dualboot, und unter windows funktioniert die Karte ja einwandfrei.

Ich denke, da ist irgendwo ein Konfigurationsfehler bei mir - aber ich hab nicht die geringste Ahnung, wo ich zu suchen anfangen könnte - kann mal wer zusammenfassen, welche files alle relevant sind?


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 25.11.2008, 22:26    (Kein Titel) Antworten mit ZitatNach oben

und noch was, das evtl irgendjemandem helfen könnte:
gelse@fliegenmini:~$ ifconfig ppp0
ppp0      Link encap:Punkt-zu-Punkt-Verbindung 
          inet Adresse:77.119.180.149  P-z-P:10.64.64.64  Maske:255.255.255.255
          UP PUNKTZUPUNKT RUNNING NOARP MULTICAST  MTU:1440  Metrik:1
          RX packets:22 errors:1 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:3
          RX bytes:1612 (1.6 KB)  TX bytes:1466 (1.4 KB)

gelse@fliegenmini:~$ route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
10.64.64.64     0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 ppp0
0.0.0.0         10.64.64.64     0.0.0.0         UG    0      0        0 ppp0
gelse@fliegenmini:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 213.94.78.16
nameserver 213.94.78.17


evtl kann das jemand, der eine funktionierenden drei-Zugang hat vergleichen?

danke

ps: DNS funktioniert, ping aber nicht:
gelse@fliegenmini:~$ nslookup gelse.net
Server:      212.33.55.5
Address:   212.33.55.5#53

Non-authoritative answer:
Name:   gelse.net
Address: 195.47.247.89
gelse@fliegenmini:~$ ping www.google.at
PING www.l.google.com (74.125.43.147) 56(84) bytes of data.
From 172.16.12.111 icmp_seq=1 Destination Host Unreachable
From 172.16.12.111 icmp_seq=2 Destination Host Unreachable



Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 25.11.2008, 23:17    (Kein Titel) Antworten mit ZitatNach oben

mm@mm-laptop%u3a~$ ifconfig ppp0
ppp0      Link encap%u3aPoint-to-Point Protocol
          inet addr%u3a77.119.XX.XX P-t-P%u3a10.64.64.64  Mask%u3a255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU%u3a1500  Metric%u3a1
          RX packets%u3a9963 errors%u3a0 dropped%u3a0 overruns%u3a0 frame%u3a0
          TX packets%u3a7394 errors%u3a0 dropped%u3a0 overruns%u3a0 carrier%u3a0
          collisions%u3a0 txqueuelen%u3a3
          RX bytes%u3a11020511 %u2811.0 MB%u29  TX bytes%u3a1002297 %u281.0 MB%u29


ich hab kein Passwort bei meinem drei zugang. d.h. benutzer und passwort leer lassen

EDIT!!: Zusätzlich ist IPv4 settings auf Automatic (PPP) zu setzen ohne adress only.
Zumindest hab ichs so.

der rest sollte passen. hab ich genauso


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 26.11.2008, 00:02    (Kein Titel) Antworten mit ZitatNach oben

danke, hab ich ausprobiert, nutzt nichts. selbes wieder. komm nur auf die "leider nicht"-drei seite.

d.h. datenverbindung steht, aber ich werde von drei umgeleitet.
was ich allerdings SCHON aufrufen kann, ist http://www.drei.at/
edit: hab die seite ein paarmal geladen - lokal ist kein cache, und sie lädt durchschnittlich schnell, also scheint die Datenverbindung an sich schon zu stimmen.

bzgl username/passwort:
- auch mit drei.at/drei.at funktioniert umtsmon jetzt nicht mehr - das war wohl nur zufall, dass das kurz mal wenigstens verbunden hat.
- den usernamen kann ich rauslöschen, das passwort schreibt er immer wieder von selbst rein
edit: das lag am passwort-manager, hab das durchprobiert - es ändert genau garnichts, egal was ich da reintu. hab drei/drei drei.at/drei.at und leer/leer ausprobiert.

hab auch schon in gconf nachgeschaut. network manager speichert dort angeblich unter /system/networking/connections/ die verbindungen.
Dort hab ich einstellungen für GSM (zB den type) gefunden - jetzt weiss ich allerdings nicht, ob das ok ist, oder nicht; für dieses ganze neumodische klumpert gibts noch nirgends ordentliche manuals im netz. wink


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 26.11.2008, 10:18    (Kein Titel) Antworten mit ZitatNach oben

lösch mal das profil ausm network manager und legs neu an, vielleicht funktionierts dann.

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 26.11.2008, 10:36    (Kein Titel) Antworten mit ZitatNach oben

das hab ich auch schon getan, ohne Erfolg.
die datenverbindung steht ja, ich werd nur immer umgeleitet auf die drei-'leider nicht'-seite.

Er legt das Profil dann freilich mit den Daten in ServiceProviders.xml (aus dem anderen thread) an, d.h. wenn es an dem liegt, dann müsst ichs dort ändern.
Allerdings hab ich das ServiceProviders.xml eben von hier - und das funktioniert ja angeblich bei anderen.

Daraus kann man aber eigentlich schliessen, dass es an was anderem liegen muss als an den Einstellungen vom network manager.

Ich vermute, dass er aus irgendeinem Grund die routing-table falsch setzt. kann mir mal wer, der eine drei datacard hat, den output von 'route -n' sagen - bzw vergleichen mit dem, was ich weiter oben gepostet hab?

lg


Zuletzt bearbeitet von Gast am 26.11.2008, 10:47, insgesamt einmal bearbeitet


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit


Zuletzt bearbeitet von Gast am 26.11.2008, 10:47, insgesamt einmal bearbeitet
Online    
Gast











BeitragVerfasst am: 26.11.2008, 10:41    (Kein Titel) Antworten mit ZitatNach oben

routing ist exactly the same bei mir. Ich denke es ist etwas trivialeres wie das passwort. Ich hab gerade das passwort und benutzer bei mir eingetragen. dabei ging die verbindung nicht mehr. ich habs jetzt wieder rausgelöscht, habs zwar das passwort noch drinnen stehen (anscheinend) aber es funktioniert dafür wieder.

Edit:

Was zeigt er dir eigentlich bei IPv4 settings/Routes an? hast das Automatic schon umgestellt?

Edit#2:
Grundlegende Frage: Warum hast du umtsmon zusätzlich installiert? Hat bei dir das Modem von haus aus nicht out-of-the-box funktioniert?


Zuletzt bearbeitet von Gast am 26.11.2008, 10:53, insgesamt 2-mal bearbeitet


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit


Zuletzt bearbeitet von Gast am 26.11.2008, 10:53, insgesamt 2-mal bearbeitet
Online    
Gast











BeitragVerfasst am: 26.11.2008, 10:50    (Kein Titel) Antworten mit ZitatNach oben

habs mit voll DHCP probiert, habs mit DHCP IP, aber DNS manuell (wie von der ServiceProviders.xml vorgegeben) probiert.

inwiefern ging die verbindung nicht mehr? konnte er nicht mehr aufbauen, oder wars was anderes?
Weil so wies aussieht bin ich ja der einzige, der die 'leidernicht'-Seite bekommt (siehe Attachment planet3.png weiter oben).


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 26.11.2008, 10:57    (Kein Titel) Antworten mit ZitatNach oben

verbindung konnte nicht mehr aufgebaut werden.

ließ meine edits bitte Smile


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050175594 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1095s (PHP: 72% - SQL: 28%) | SQL queries: 90 | GZIP enabled | Debug off ]