Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Yesss! Mobiles Breitband - ZTE MF626 - Problem beim Verbinde

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 02.06.2009, 12:06    Yesss! Mobiles Breitband - ZTE MF626 - Problem beim Verbinde Antworten mit ZitatNach oben

Hallo!

Ich hab mir jetzt ein mobiles Breitband zugelegt und brings leider nicht zum Laufen. Das Modem (ZTE MF626) hab ich mit folgender Anleitung konfiguriert. http://ubuntuforums.org/showthread.php?t=1147685

Daraufhin wurde es auch vom Network Manager erkannt und ich bin den Anweisungen zum Erstellen der neuen Verbindung gefolgt und habe dabei meinen Anbieter Yesss! ausgewählt. Dabei schien alles zu funktionieren. Das Problem ist, dass ich mich jetzt aber nicht verbinden kann. Er versucht es zwar, zeigt dann aber schlussendlich immer "Verbindung getrennt" an.

Im syslog findet sich folgendes:
May 28 20:07:55 ntb-stefan NetworkManager: <info>  Activation (ttyUSB4) starting connection 'Yesss'
May 28 20:07:55 ntb-stefan NetworkManager: <info>  (ttyUSB4): device state change: 3 -> 4
May 28 20:07:55 ntb-stefan NetworkManager: <info>  Activation (ttyUSB4) Stage 1 of 5 (Device Prepare) scheduled...
May 28 20:07:55 ntb-stefan NetworkManager: <info>  Activation (ttyUSB4) Stage 1 of 5 (Device Prepare) started...
May 28 20:07:55 ntb-stefan NetworkManager: <debug> [1243534075.629571] nm_serial_device_open(): (ttyUSB4) opening device...
May 28 20:07:55 ntb-stefan NetworkManager: <info>  Activation (ttyUSB4) Stage 1 of 5 (Device Prepare) complete.
May 28 20:07:55 ntb-stefan NetworkManager: <WARN>  init_done(): Trying alternate modem initialization (1)
May 28 20:07:57 ntb-stefan NetworkManager: <WARN>  init_done(): Trying alternate modem initialization (2)
May 28 20:07:58 ntb-stefan NetworkManager: <WARN>  init_done(): Trying alternate modem initialization (3)
May 28 20:07:59 ntb-stefan NetworkManager: <WARN>  init_done(): Trying alternate modem initialization (4)
May 28 20:08:00 ntb-stefan NetworkManager: <info>  (ttyUSB4): GSM pin secret required
May 28 20:08:00 ntb-stefan NetworkManager: <info>  (ttyUSB4): device state change: 4 -> 6
May 28 20:08:00 ntb-stefan NetworkManager: <info>  Activation (ttyUSB4) Stage 1 of 5 (Device Prepare) scheduled...
May 28 20:08:00 ntb-stefan NetworkManager: <info>  Activation (ttyUSB4) Stage 1 of 5 (Device Prepare) started...
May 28 20:08:00 ntb-stefan NetworkManager: <info>  (ttyUSB4): device state change: 6 -> 4
May 28 20:08:00 ntb-stefan NetworkManager: <debug> [1243534080.049473] nm_serial_device_open(): (ttyUSB4) opening device...
May 28 20:08:00 ntb-stefan NetworkManager: <info>  Activation (ttyUSB4) Stage 1 of 5 (Device Prepare) complete.
May 28 20:08:00 ntb-stefan NetworkManager: <WARN>  init_done(): Trying alternate modem initialization (1)
May 28 20:08:01 ntb-stefan NetworkManager: <WARN>  init_done(): Trying alternate modem initialization (2)
May 28 20:08:02 ntb-stefan NetworkManager: <WARN>  init_done(): Trying alternate modem initialization (3)
May 28 20:08:03 ntb-stefan NetworkManager: <WARN>  init_done(): Trying alternate modem initialization (4)
May 28 20:08:04 ntb-stefan NetworkManager: <info>  (ttyUSB4): powering up...
May 28 20:08:04 ntb-stefan NetworkManager: <info>  Searching for a network...
May 28 20:08:14 ntb-stefan last message repeated 9 times
May 28 20:08:15 ntb-stefan NetworkManager: <info>  Registered on Home network
May 28 20:08:15 ntb-stefan NetworkManager: <info>  Associated with network: +COPS: 0,0,"Orange Austria",2
May 28 20:08:47 ntb-stefan NetworkManager: <WARN>  dial_done(): Dialing timed out
May 28 20:08:47 ntb-stefan NetworkManager: <info>  (ttyUSB4): device state change: 4 -> 9
May 28 20:08:47 ntb-stefan NetworkManager: <debug> [1243534127.011285] nm_serial_device_close(): Closing device 'ttyUSB4'
May 28 20:08:47 ntb-stefan NetworkManager: <info>  Marking connection 'Yesss' invalid.
May 28 20:08:47 ntb-stefan NetworkManager: <info>  Activation (ttyUSB4) failed.
May 28 20:08:47 ntb-stefan NetworkManager: <info>  (ttyUSB4): device state change: 9 -> 3
May 28 20:08:47 ntb-stefan NetworkManager: <info>  (ttyUSB4): deactivating device (reason: 0).
May 28 20:08:47 ntb-stefan kernel: [ 6846.818917] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
May 28 20:08:47 ntb-stefan kernel: [ 6846.818949] option 1-3:1.0: device disconnected
May 28 20:08:47 ntb-stefan kernel: [ 6846.819292] option 1-3:1.1: device disconnected
May 28 20:08:47 ntb-stefan NetworkManager: <info>  Policy set 'GIULIANI' (wlan0) as default for routing and DNS.
May 28 20:08:47 ntb-stefan kernel: [ 6846.819540] option1 ttyUSB5: GSM modem (1-port) converter now disconnected from ttyUSB5
May 28 20:08:47 ntb-stefan kernel: [ 6846.819591] option 1-3:1.3: device disconnected
May 28 20:08:47 ntb-stefan NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
May 28 20:08:47 ntb-stefan NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
May 28 20:08:47 ntb-stefan nm-system-settings:    SCPlugin-Ifupdown: devices removed (udi: /org/freedesktop/Hal/devices/usb_device_19d2_31_noserial_if3_serial_usb_0)
May 28 20:08:47 ntb-stefan kernel: [ 6846.929147] usb 1-3: reset high speed USB device using ehci_hcd and address 22
May 28 20:09:02 ntb-stefan kernel: [ 6862.040158] usb 1-3: device descriptor read/64, error -110


Kennt jemand dieses Problem oder hat einen Lösungsansatz?

Liebe Grüße,
Stefan


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 02.06.2009, 12:23    (Kein Titel) Antworten mit ZitatNach oben

Hello

Nun, ich weiß, das es mit dem ZTE MF 626 eine Menge Problem gibt...
Du bist ja schon weit gekommen, wenn dein Modem auch als solches erkannt wird...

Einen Thread dafür gibt es hier... bzw. vielleicht hilf dir das kleine Script...

Die Ausgabe von dmesg enthält ja auch einige Errors
May 28 20:08:47 ntb-stefan NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
May 28 20:09:02 ntb-stefan kernel: [ 6862.040158] usb 1-3: device descriptor read/64, error -110


Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 02.06.2009, 12:31    (Kein Titel) Antworten mit ZitatNach oben

Danke für die rasche Antwort!
Ok, das klingt alles nicht so toll... Ich hätte die Möglichkeit, das MF626 zurückzugeben.
Welches andere Modem würdest du empfehlen? Ich hab nämlich gehört, dass die Huawei nicht so gut funktionieren wie die ZTE (was Empfang und Verbinden betrifft, ich meine nicht die Linux-Kompatibilität).

Stefan


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 02.06.2009, 12:46    (Kein Titel) Antworten mit ZitatNach oben

hmmmm... also lieber ein Huawei, dass "angeblich" nicht so gut funktioniert, als eines, dass gar nicht funktioniert Wink
Ich habe schon mit vielen Modems gearbeitet, Probleme gab es mit Huawei nirgends...
Eines, dass gut funktioniert ist das E160, habe auch die anderen passen...
Wir haben hier eine Modem-Datenbank... da kannst du ja mal nachsehen.
Es es ist jeder eingeladen, sein funktionierendes Modem dort einzutragen!

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 28.10.2009, 03:16    (Kein Titel) Antworten mit ZitatNach oben

Hallo Webbutterfly,

ich denke, einen Weg gefunden zu haben, das ZTE MF626 in Ubuntu 8.04 zum Laufen zum bringen - zumindest funktioniert es bei mir.

1. USB-Modeswitch 0.9.7-1 war bereits installiert
2. Dann habe ich mit Rootrechten die Datei "/usr/share/hal/fdi/information/20thirdparty/20-zte-mf626.fdi" erstellt wie [http://www.taringa.net/posts/linux/2318037/Configurar-internet-en-Ubuntu-modem-ZTE-mf626.html hier] in Punkt 10) beschrieben.
3. Als letztes habe ich in der Datei "/etc/udev/rules.d/usb_modeswitch.rules" bei den Einstellungen für das ZTE MF 626 die Raute vor "SUBSYSTEM" entfernt:

[########################################################
# ZTE MF628+ (tested version from Telia / Sweden)
# ZTE MF626
#
# Contributor: Joakim Wennergren
# if that command doesn't work, try the other ("eject")
# Vendor:Product id = 0x19d2:0x2000
SUBSYSTEM=="usb", SYSFS{idVendor}=="19d2", SYSFS{idProduct}=="2000", RUN+="/usr/sbin/usb_modeswitch --DefaultVendor 0x19d2 --DefaultProduct 0x2000 --MessageEndpoint 0x01 --MessageContent 5553424312345678000000000000061b000000030000000000000000000000"
]

Danach wurde das Modem nach einem Neustart erkannt und konnte ich verbinden, egal ob der Stick schon vorher angesteckt war oder erst nachher angesteckt wurde.

Ich hoffe, dass ich nichts vergessen habe, da ich doch einige Stunden herumprobiert habe.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050175906 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1178s (PHP: 81% - SQL: 19%) | SQL queries: 45 | GZIP enabled | Debug off ]