Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 9.10 ZTE udev Rule zieht nicht

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 21.02.2010, 11:15    9.10 ZTE udev Rule zieht nicht Antworten mit ZitatNach oben

Ich glaub ich habs!
Ein Poster hat vorher im falschem Thread (9.04) diese Frage gestellt, darum hier jetzt ein extra Thread:

Karmic hat zwar schon eine udev Rule für ZTE Modems (simples eject), aber diese zieht bei manchen Leuten nicht, weil die Rules in falscher Reihenfolge exekutiert werden. (Achtung: Vendor/ProduktId muß 19d2:2000 sein)

https://wiki.ubuntu.com/NetworkManager/Hardware/3G/ZTE_MF622 (das 9.04 Gewäsch ist ziemlich veraltet, pls ignore)

Zitat:

Ubuntu 9.10
Changing udev rules
Those experiencing similar problem in Karmic may try this simple step :
Rename /lib/udev/rules.d/61-mobile-action.rules to /lib/udev/rules.d/51-mobile-action.rules
Then unplug the modem, and plug it again.
This time it should be detected after a while by Karmic.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 25.02.2010, 16:39    hi Antworten mit ZitatNach oben

habe deine anleitung gelesen - allerdings ist es mir nicht möglich

Rename /lib/udev/rules.d/61-mobile-action.rules to /lib/udev/rules.d/51-mobile-action.rules

ein tipp wäre hilfreich

vielen dank im vornherein

alex


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 25.02.2010, 16:44    (Kein Titel) Antworten mit ZitatNach oben

Hello

..der Befehl im Terminal lautet:
sudo mv /lib/udev/rules.d/61-mobile-action.rules  /lib/udev/rules.d/51-mobile-action.rules


... im Beitrag von Kappa ist nur angegeben, welche Datei man umbenennen muss...

bzw. ALT+F2 >gksu nautilus
in den Ordner /lib/udev/rules.d wechseln, >rechte Maustaste auf 61-mobile-action.rules >umbenennen: 51-mobile-action.rules

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 25.02.2010, 16:50    danke Antworten mit ZitatNach oben

habe noch meine probleme mit dem terminal

thx für die rasche antwort

lg alex


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 25.02.2010, 17:15    (Kein Titel) Antworten mit ZitatNach oben

..was mich an diesem Thread stört, dass hier nur von einem ZTE-Modem die Rede ist....
Es gibt das einige Modelle und ich denke, dass die Rules zu dem jeweiligen Modem passen müssen...

Das Workaround scheint ja nur für das ZTE MF622 zu sein, oder irre ich mich...
produkt und vendor ID sind ja bei den Modellen nicht identisch.

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 25.02.2010, 17:39    (Kein Titel) Antworten mit ZitatNach oben

Hallo, richtig, diese udev Rule, welche im Karmic mitkommt, sagt nix anders als: Wenn 19d2:2000 , dann mache eject.

Diese IDs habe ich oben auch erwähnt.
Also, Gefahr kann nur bestehen, wenn mit Fixes im Karmic neue Rules kommen, welche die Orig. Reihenfolge der Files brauchen.
(kommt sicher) Smile


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 25.02.2010, 17:46    (Kein Titel) Antworten mit ZitatNach oben

OK, passt...

Mein MF ZTE628 meldet sich mit:19d2:2000 und nach dem aushängen des Zero-Laufwerkes mit: 19d2:0015
..dann funzt es einwandfrei.

PS: habe mir das Ganze nicht durchgesehen...

Marion

EDIT: funktioniert mit dem MF628 nicht! (9.10-64)


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 25.02.2010, 18:09    (Kein Titel) Antworten mit ZitatNach oben

Mein ZTE-MF628 funktioniert nach dem "händischen" aushängen problemlos...
Siehe Video...

Marion


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 25.02.2010, 18:16    (Kein Titel) Antworten mit ZitatNach oben

Neue Idee - siehe unten!
Mist, das ist eine simple udev Rule!
# modem-modeswitch does not work with these devices, the fake CD-ROM needs to be ejected
# ZTE MF6xx
ACTION=="add", ENV{ID_CDROM}=="1", ENV{ID_VENDOR_ID}=="19d2", ENV{ID_MODEL_ID}=="2000", RUN+="/usr/bin/eject %k"

Das udev Zeugs fällt unter das Glücksspielgesetz.
Ich müßte das udev Processing mitloggen, das trifft sicher nicht nur ZTE Modems.

Bin enttäuscht, demotiviert.
Danke für den Check
--Hannes

Was ist, wenn danach die ProductId von udev nicht neu eingelesen wrid, sondern das Rule File
77-mm-zte-port-types.rules
mit der falschen ProductId=2000 weiterverarbeitet wird? Dann werden die falschen /dev/USB* Files
vom Modemmanager angesprochen.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 04.03.2010, 21:27    ubuntu 10.04 lts + zte mf636 Antworten mit ZitatNach oben

danke für die anleitungen und es hat tatsächlich funtioniert

zuerst

sudo mv /lib/udev/rules.d/61-mobile-action.rules /lib/udev/rules.d/51-mobile-action.rules

wie mir empfohlen wurde

danach mein VPN konfigurieren und das ZTE modem wird ekannt

in meinem Fall - Austria + Three

danach nur bei der tel #99 - die tel einfügen und die pin-code-abfrage
deaktivieren

AUF JEDEN FALL DANKE FÜR EURE HILFE


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050208621 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1075s (PHP: 72% - SQL: 28%) | SQL queries: 70 | GZIP enabled | Debug off ]