Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 GrafikKarte ATI AGP X1550, ubuntu 10.04

Dieses Forum ist gesperrt, du kannst keine Beiträge editieren, schreiben oder beantworten.Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.
Autor Nachricht
bonobo




Geschlecht:
Alter: 52
Anmeldungsdatum: 25.12.2009
Beiträge: 164
Wohnort: linz


austria.gif

BeitragVerfasst am: 24.04.2010, 00:18    GrafikKarte ATI AGP X1550, ubuntu 10.04 Antworten mit ZitatNach oben

GraKa ATI AGP X1550 256MB 64BIT GDDR2 (Verpackungstext)
lspci:
01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]
01:00.1 Display controller: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series] (Secondary)
Monitor:
LG 1919 (1280x1024) LCD
1)
Treiber xserver-xorg-video-radeonhd
(über xorg.conf geladen, ohne xorg.conf wird ..xorg-video-ati(radeon) geladen)

Xorg.log.0:
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-25-server i686 Ubuntu
Current Operating System: Linux darkstar 2.6.32-21-generic #32-Ubuntu SMP
....
(II) RADEONHD(0): AtomBIOS VRAM scratch base: 0x1000000
(WW) RADEONHD(0): rhdAtomAllocateFbScratch: FW FB scratch area not located at the end of VRAM. Scratch End: 0x1005000 VRAM End: 0x10000000
(II) RADEONHD(0): Cannot get VRAM scratch space. Allocating in main memory instead
....
(II) RADEONHD(0): [drm] installed DRM signal handler
(WW) RADEONHD(0): [agp] AGP not available
(EE) RADEONHD(0): [agp] AGP failed to initialize. Disabling the DRI.
....
(II) RADEONHD(0): Current Memory Clock: 396000
(WW) RADEONHD(0): Unusupported SetVoltage Revision
(II) RADEONHD(0): Using MMIO Command Submission for acceleration.

Funktion ist aber ansonsten OK
hochauflösenden Videos werden aber nur ruckelig wiedergegeben
(mplayer videoausgabe über X11)
2d leistung ist Zufriedenstellend

Nachdem keine xorg.conf vorhanden war habe ich eine erstellt.
ohne Erfolg

Danach habe ich noch "xserver-xorg-video-radeonhd" selbst compeliert. (wiki.ubutuusers.de)
Rechner eingefroren. (Neustart,Treiber deinstalliert,Orignal installiert)
läuft wieder

2)
Treiber xserver-xorg-video-ati (radeon)

Vorteil: hochauflösende Videos werden viel besser wiedergegeben.
(mplayer videoausgabe über XV)
Nachteil: 2D(Vetorgrafiken,CAD) sehr langsam.
ist derzeit deinstalliert

(II) VESA: driver for VESA chipsets: vesa
(II) FBDEV: driver for framebuffer: fbdev
(II) Primary Device is: PCI 01@00:00:0
(II) [KMS] Kernel modesetting enabled.
(WW) Falling back to old probe method for vesa
(WW) Falling back to old probe method for fbdev
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib/xorg/modules/linux/libfbdevhw.so

neuen Treiber so installiert:

sudo add-apt-repository ppa:xorg-edgers/drivers-only

aber keine Verbesserung

Meine Frage wäre kann man in der xorg.conf etwas eintragen
um einen der beiden Treiber anständig zum laufen zu bringen.

lg.

PS.:
Ich bin von Ubuntu 8.10 etwas verwöhnt, da gabst noch den
proprietären fglrx-Treiber für meine Karte.

Anhang: xorg.conf


Desktop: LXDE Lubuntu

Version: 12.04

Hardware: Workstation

Architektur: 32Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenE-Mail senden    
kappa




Geschlecht:
Alter: 47
Anmeldungsdatum: 26.10.2009
Beiträge: 1466
Wohnort: Wien 10


austria.gif

BeitragVerfasst am: 24.04.2010, 06:26    (Kein Titel) Antworten mit ZitatNach oben

Hi mein Ratschlag dazu:

1) KMS testweise abdrehen
2) Sonst alles autom. konfigurieren lassen, nicht mit xorg.conf spielen
3) Noch paar Tage warten

Derzeit gibt es einen dicken Fisch im X Server, hat sich Ubuntu gerade eingefangen, steht auch auf Heise.de, bitte das offizielle Lucid abwarten.

KMS ist jetzt mit Lucid fast überall im Einsatz, ist aber radikaler Wechsel!
Probiers mit und ohne.

Wenn Du selbst konfigurierst, wird natürlich die Analyse noch schwieriger, weil noch mehr Sonderfälle entstehen. Warte noch damit, laß ihn derzeit ohne Xorg.conf werkeln.


Desktop: Gnome 2.X

Version: 10.04

Hardware: Notebook

Architektur: 32Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht senden    
Webbutterfly
Administrator



Geschlecht:
Alter: 61
Anmeldungsdatum: 24.06.2006
Beiträge: 6918
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 24.04.2010, 10:53    (Kein Titel) Antworten mit ZitatNach oben

Zitat:
Derzeit gibt es einen dicken Fisch im X Server, hat sich Ubuntu gerade eingefangen, steht auch auf Heise.de, bitte das offizielle Lucid abwarten.

...passt nicht ganz...
Ist am 15. April passiert und beinhaltet ein Speicherloch im GLX.
(Wer an diesem Tag noch kein 10.04 installiert hatte oder kein Update gemacht hat, ist nicht betroffen)
Infos und ein Workaround gibt es hier: GEM memory leak from GLX 1.3/1.4 backport
betrifft aber nur "freie" Treiber, speziell Intel.
Prüfen kann man es, in den man glxinfo installiert und dann aufruft:
sudo apt-get install glxinfo

glxinfo | grep "GLX version"

hier sollte 1.2 angezeigt werden und nicht 1.4


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
bonobo




Geschlecht:
Alter: 52
Anmeldungsdatum: 25.12.2009
Beiträge: 164
Wohnort: linz


austria.gif

BeitragVerfasst am: 24.04.2010, 15:25    (Kein Titel) Antworten mit ZitatNach oben

@kappa
Danke Super Tip, KMS ausschalten war goldrichtig

habe in der Datei
/etc/default/grub den Eintrag GRUB_CMDLINE_LINUX="nomodeset" gesetzt

1) Leider startet jetzt der usplash-nachfolger und die
Konsole mit 640x480

2) Änderung in /etc/default/grub
GRUB_GFXMODE=1280x1024 bringt nix, ist nur für das Grubmenu
gabs da nicht in grub1 -vga 795 od. ähnl. ?

INFOS
-------------------------------------------------------
radeonhd mit xorg.conf ohne KMS
......................
bonobo@darkstar:~$ glxgears
3726 frames in 5.0 seconds

bonobo@darkstar:~$ glxinfo | grep "GLX version"
GLX version: 1.2

mplayer mit XV viedeoausgabe (mit ati erkennung)
--------------------------------------------------------
radeonhd mit xorg.conf mit KMS
......................

bonobo@darkstar:~$ glxgears
701 frames in 5.0 seconds

bonobo@darkstar:~$ glxinfo | grep "GLX version"
GLX version: 1.2

mplayer nur mit X11 videoausgabe
-------------------------------------------------------
ati(radeon) ohne xorg.conf mit KMS
..........................

bonobo@darkstar:~$ glxgears
ca. 60 frames in 5.0 seconds

bonobo@darkstar:~$ glxinfo | grep "GLX version"
GLX version: 1.4 !

mplayer mit XV viedeoausgabe (mit ati erkennung)
---------------------------------------------------------


lg.


Desktop: LXDE Lubuntu

Version: 12.04

Hardware: Workstation

Architektur: 32Bit
OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenE-Mail senden    
Beiträge der letzten Zeit anzeigen:      
Dieses Forum ist gesperrt, du kannst keine Beiträge editieren, schreiben oder beantworten.Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050150930 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1187s (PHP: 82% - SQL: 18%) | SQL queries: 40 | GZIP enabled | Debug off ]