Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Ubuntu kennt HUAWEI E1552 USB Modem nicht.

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 20.09.2009, 20:14    Ubuntu kennt HUAWEI E1552 USB Modem nicht. Antworten mit ZitatNach oben

Ein Bekannter von mir möchte sein neu gekauftes YESSS! USB Modem
Modell: Huawei E1552 unter Ubuntu Linux betreiben.

Das Modem wird von Ubuntu 9.04 nicht erkannt.

Hat irgendjemand eine Idee?

Danke!

LG
Michael


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 21.09.2009, 16:58    (Kein Titel) Antworten mit ZitatNach oben

http://forum.ubuntu-fi.org/index.php?topic=28821.0

Here is a method (workaround) to use the Huawei E1550 Mobile Broadband HSDPA 3.6Mbps modem in Ubuntu with the Network Manager. Open a terminal and follow the three steps:

1) Install udev-extras from the standard Ubuntu repositories:
sudo apt-get update && sudo apt-get install udev-extras


2) Add a custom udev rule for the Huawei E1550 by typing this line:
echo 'SUBSYSTEM=="usb", SYSFS{idProduct}=="1446", SYSFS{idVendor}=="12d1", RUN+="/lib/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"' | sudo tee  /etc/udev/rules.d/45-huawei1552.rules


3) Configure explicitly the Mobile Broadband on Network Manager according to specific instructions from your provider. In my case I just had to fill in the APN. It is convenient to check the box that the connection will be activated automatically and will be available for all users.



Weiter unten auf der Seite stehen nochmal ähnliche Befehle.
Da ich kein Finnisch kann, weiß ich nicht was unten steht :/


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 21.09.2009, 20:57    (Kein Titel) Antworten mit ZitatNach oben

hier gibt es das Ganze in Englisch...
http://ubuntuforums.org/showthread.php?t=1211787
dritter Post...
Empfohlene Suche immer mit: http://www.uboontu.com/


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 21.09.2009, 21:45    (Kein Titel) Antworten mit ZitatNach oben

Vielen Dank, lg Michael

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 06.12.2009, 04:26    (Kein Titel) Antworten mit ZitatNach oben

Hi all,
bei mir funktioniert das leider nicht ... verwende das E1552 von Orange.
Hat das schon jemand laufen? Wahrscheinlich happerts an den id´s?
Danke & LG


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 64
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 06.12.2009, 10:59    (Kein Titel) Antworten mit ZitatNach oben

Hello

Sorry, aber
bei mir funktioniert das leider nicht
ist zu wenig...
Bitte um mehr Angaben bzw. was hast du gemacht? was kommt für eine Fehlermeldung? was funktioniert wie wo nicht?
Das Modem bzw. die SIM-Karte auch schon bei Orange aktiviert?


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 06.12.2009, 13:37    (Kein Titel) Antworten mit ZitatNach oben

Hi, habe sowohl den von Airflash im zweiten Thread angeführten Weg versucht als auch diesen:
http://neildecapia.wordpress.com/2009/07/05/globe-tattoo-on-ubuntu-jaunty-9-04/

Es kommt weder eine Fehlermeldung noch reagiert LED mäßig das Modem nicht - in beiden Fällen. Habe idVendor idProduct mit lsusb gecheckt - sollt passen.

Modem ist ein Huawei E1552 von Orange Austria, Sim bereits aktiviert. Ubuntu 9.04
Thx


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 09.12.2009, 15:17    (Kein Titel) Antworten mit ZitatNach oben

Ich habs mit Gnome-PPP geschafft (mit dem Network-Manager gehts net gscheit, der schaffts manchmal nach X mal probieren):

Installation:
sudo apt-get install gnome-ppp

Vorbereitung:
* User muss in der Gruppe "dip" sein, damit Zugriff auf /usr/sbin/pppd möglich ist.
* PIN der SIM-Karte deaktivieren (sollte mit dem Handy, der Windows Software, oder umtsmon gehen).
* Nach dem Einstecken des Modems etwas warten.

GNOME PPP:

Username: user (Ich glaub bei Username und Password kann irgendwas stehen)
Passwort: pass
Remember password: (ausgewählt)
Phone number: *99#

Setup:

[Modem]
Device: /dev/ttyUSB0
Type: USB Modem
Speed: 9600
Phone-Line: Tone
Volume: High
Dial Prefix: (leer)
Dial attempts: 1
Wait for dialtone: (nicht ausgewählt)

[Phone numbers...]
(leer)

[Init Strings...]
Init2: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3: AT^SYSCFG=14,2,3FFFFFFF,2,4 (Zwingt das Modem auf UMTS Geschwindigkeit, vorher hat es bei mir immer das sehr langsame GPRS bevorzugt).

[Networking]
* Dynamic IP address
* Automatic DNS (obwohl hier sollte man wohl die YESSS DNS Server fix eintragen, weil die nicht immer gesetzt werden. - überprüfbar mit cat /etc/resolv.conf. Wenn nicht eingetragen muss man manchmal noch einmal verbinden, bis sie da sind)

[Options]
On connection: Minimize und Dock ausgewählt
Connection:
Auto Reconnect: (nicht ausgewählt)
Abort if line busy: (nicht ausgewählt)
Abort connecting if no dialtone: (ausgewählt)
Check carrier line: (nicht ausgewählt)
Check default route: (ausgewählt)
Ignore terminal strings (Stupid mode): (ausgewählt)
Send custom reply: Nicht ausgewählt
Idle time: 0

Ich weiss nicht, ob mein /etc/wvdial.conf auch für die erfolgreiche Verbindung notwendig ist. Das schaut so aus:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1, "IP", "web.yesss.at"
Init4 = ATI
; Baud = 9600
; Baud = 460800
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = *99#
Password = globe
Username = globe
Stupid Mode = yes


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 04.05.2010, 21:55    (Kein Titel) Antworten mit ZitatNach oben

« Airflash » hat folgendes geschrieben:
http://forum.ubuntu-fi.org/index.php?topic=28821.0

3) Configure explicitly the Mobile Broadband on Network Manager according to specific instructions from your provider. In my case I just had to fill in the APN. It is convenient to check the box that the connection will be activated automatically and will be available for all users.


Die ersten 2 Punkte hab ich ausgeführt und bis dahin auch keine Probleme (glaub ich)

Jetzt weiß ich nicht was da mit Punkt 3 gemeint ist, ich benutze Orange was sind da z.b. die specific instructions vom Provider? Ich hab nur ein Kärtchen mit meinem PIN Code das was mit "Instructions".

Ich habe auch mit Hilfe von Google andere Threads zu dem Thema gefunden wo was von SIM Karte deaktivieren steht, aber nicht wie/wo/was.

Ich nehme mal an um eine Internetverbindung über das USB Modem aufzubauen muss ich nach diesen 3 Steps auch noch eine "mobile Breitband" Verbindung einrichten im Networkmanager oder?

Ich benutze aktuelle Ubuntu Version mit Gnome Dekstop.

Kann mir jemand weiter helfen?

Woran erkenne ich ob das Modem richtig erkannt wird oder nicht?

hilfe bitte Very Happy

PS: Hab auch noch einen Workaround gefunden mit Google wo man Gome PPP Packet installiert und dort was machen soll, aber da habe ich noch weniger verstanden als bei diesen 3 genannten Punkten.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 04.05.2010, 22:43    (Kein Titel) Antworten mit ZitatNach oben

Google Suche ist ja ok, wenn Du im Forum aber Hilfe willst, dann bitte halte Dich ans Forum. Schau auf die Huawei Themen zu 1550/1552.

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 04.05.2010, 23:11    (Kein Titel) Antworten mit ZitatNach oben

Der Großteil meine Beitrags bezieht sich auf diesen Thread aus diesem Forum hier, hab das mit Google nur erwähnt weil auch hier schon diese Stichworte gefallen sind.

Zu meinen Fragen weiß da jemand bescheid?

edit:

habe natürlich auch im forum schon ne suche gestartet, vieles davon betrifft nicht 10.4 und ist veraltet (denke ich?) und sonst decken sich die meisten hilfestellungen mit genau diesem aus dem Thread hier, und genau dazu habe ich fragen gestellt weil ich da eben nicht durch blicke, nix für ungut wink


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 04.05.2010, 23:16    (Kein Titel) Antworten mit ZitatNach oben

« ednat » hat folgendes geschrieben:


Die ersten 2 Punkte hab ich ausgeführt und bis dahin auch keine Probleme (glaub ich)

Jetzt weiß ich nicht was da mit Punkt 3 gemeint ist, ich benutze Orange was sind da z.b. die specific instructions vom Provider? Ich hab nur ein Kärtchen mit meinem PIN Code das was mit "Instructions".


Sieh dir bitte einmal die Anleitung zur Installation von E160E an:

http://webbutterfly.com/webbutterfly/pages/video/e160e_10.04.php

So einfach kann es funktionieren. Wenn Punkt 1 und 2 richtig sind und das Modem im Funkgebiet sich befindet, sollte es auch so einfach funktionieren.
viel Erfolg

wl

edit:
Wenn du im Terminal lsusb eingibst, werden alle USB-Geräte angezeigt - ich sehe mein Huawei Modem so:
Bus 001 Device 006: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Beunruhige dich aber nicht, wenn nicht E1552 dort steht. Wenn ein kompatibles Gerät erkannt wird, funktioniert es auch.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 04.05.2010, 23:38    (Kein Titel) Antworten mit ZitatNach oben

ok ich habe den stick (mit SIM Karte drinnen) angesteckt, im netzwerk manager habe ich nur kabelnetzwerk und funknetzwerke aufgelistet, nicht wie im video auch noch die gsm netzwerke, aber egal ich gehen einfach mit rechtsklick auf das antennensignal im panel und dann auf verbindungen bearbeiten, dann habe ich das Netzwerk-Manager Fenster offen und wechsle in den Tab "Mobiles Breitband" füge dort wie im Video eine verbindung hinzu, etwas anders als im video ich nehme an da hat sich von der alpha in diesem assistenten etwas verändert bis zum release, und dann habe ich es in der Liste breitband verbindungen.
jetzt habe ich im linksklick-menü plötzlich GSM netzwerke, dann klicke ich auf meine orange verbindung und er versucht eine her zu stellen, fragt mich nach dem PIN code den ich korrekt eingebe, modem blinkt paar mal grün, aber er bringt keine verbindung zusammen.

Empfang ist in meinem Gebiet bestimmt kein Problem.

So dann mal mein Problem ausführlicher beschrieben, wie weiß ich nun woran es fehlt, eine fehlerkonsole oder ähnliches? das feld verbindungsinformationen ist ausgegraut wenn ich keine aufgebaute verbindung aktiv habe da kann ich also schon mal nicht nach meinen fehlern suchen.
sonst noch tipps oder weiß jemand genau woran es liegt?

danke für die antworten Smile

edit:
also entweder ich hab irgendwas anders gemacht diesmal, was ich bei den letzten 4 versuchen nicht getan habe, oder aus- und einstecken hat das problem behoben o.O
Naja wie dem auch sei es scheint jetzt zu gehn nachdem ich es aus-ein gesteckt habe, danke für die beiträge hier.

und gute nacht Smile


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 04.05.2010, 23:52    (Kein Titel) Antworten mit ZitatNach oben

Hallo ednat.

Wenn ich mir diesen Post von Webbutterfly durchlese, dann brauchst du nur usb-modeswitch zu installieren und es sollte funktionieren.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050186377 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.1487s (PHP: 75% - SQL: 25%) | SQL queries: 91 | GZIP enabled | Debug off ]