Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 Erfolgreiches Upgrade

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Bluemchen Blau
Supermoderator



Geschlecht:
Alter: 50
Anmeldungsdatum: 23.03.2008
Beiträge: 1078
Wohnort: Wien West


austria.gif

BeitragVerfasst am: 09.09.2014, 14:32    Erfolgreiches Upgrade Antworten mit ZitatNach oben

Servus in die Runde der Ubunturisten!

Ich wollte nur kurz berichten, daß ich "mit einem beherzten do-release-upgrade" in einer ssh-Session (im LAN) meinen Server mit den u.g. Tasks von 10.04.x auf 12.04.5 aktualisiert habe.
Am Server sind installiert (nicht alle genutzt)
i server   Basic Ubuntu server
i openssh-server   OpenSSH server
...
i lamp-server   LAMP server
i mail-server   Mail server
...
i samba-server   Samba file server
...
i virt-host   Virtual Machine host
...


Aufgetretene "Probleme":
* Ein Eintrag in der Grub-Config war nicht mehr erwünscht:
Generating grub.cfg ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.

Das war aber mit einer, leicht im Netz zu findenden, Anpassung von /etc/grub/conf schnell behoben.

* Der nfs-Server hatte ein Abhängigkeitsproblem (libtirpc1) welches aber mit Aptitude ebenso leicht zu bereinigen war.

Sonst waren vor dem Upgrade eine Aktualisierung des Systems und nach dem Upgrade nur mehr die Entfernung alter Pakete & Kernel samt reboot notwendig.
Trotz "Warnung", daß ein Upgrade besser nicht mit ssh-Verbindung durchzuführen wäre gab es damit überhaupt keine Problem. Es wurde ja sogar ein Extra-Port (1022) für den Notfall zusätzlich geöffnet.

Fazit: Aktualisierung von 10.04 auf 12.04 kinderleicht!
(Der Server wäre auch ohne die Nacharbeiten weitgehend problemlos weitergelaufen, da ich ihn hauptsächlich als Web-Server verwende und nfs praktisch nicht im Einsatz ist.)

Fazit 2: Jetzt wird mir die Aktualisierung auf 14.04.1 angeboten ... Cool


Desktop: Unity Gnome 3.X and LXDE Lubuntu

Version: 14.04 and 16.04

Hardware: Notebook and Server

Architektur: 32Bit and 64Bit

_________________
HW I: Lenovo ThinkPad X220, i7-2640M, 8GB RAM, 512GB SSD, 12,5" MATT, Ubuntu 14.04.X
HW II: HP Elitebook 2560p, i5-2520M, 8GB RAM, 500GB SSD, 12,5" MATT, Ubuntu 16.04.x (Mainline-Kernel)
HW III: Dell Latitude E4200, U9600, 3GB, 64GB SSD, 12" MATT, Apricity OS 64 Bit
Auch auf http://www.android-austria.info
OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenE-Mail sendenWebsite dieses Benutzers besuchenYahoo MessengerMSN MessengerSkype NameICQ-Nummer    
Bluemchen Blau
Supermoderator



Geschlecht:
Alter: 50
Anmeldungsdatum: 23.03.2008
Beiträge: 1078
Wohnort: Wien West


austria.gif

BeitragVerfasst am: 27.10.2014, 17:48    2. Kapitel Antworten mit ZitatNach oben

Da ich nun die Nachricht bekommen habe, daß WUALA den nicht bezahlenden Kunden mit Ende 2014 "den Hahn abdreht" wurde es Zeit für mich, sich mit OwnCloud zu beschäftigen.

Und weil mein Server noch ca. 130 GB auf der Platte frei hat, soll die OwnCloud auch wirklich "my-Own Cloud" werden. Und das am besten auf einem aktuellen System. Daher ... Upgrade des Servers von 12.04.5 auf 14.04.1! Mr. Green

Das Upgrade lief wie bereits von 10.04 auf 12... nach einem Download von 242 MB zügig durch und es waren auch keine beunruhigenden Fehlermeldungen zu verzeichnen.
Der neue Kernel drauf, das System wird ja auch brav wieder geputzt nach dem Upgrade und "schwupps", ist es ein Server mit der aktuellen LTS-Version.

Soweit so gut. ABER: Der erste Versuch meine Homepage aufzurufen erhöht plötzlich sprunghaft den Blutdruck. Ich komme zu einer recht einfach gehaltenen Seite, die mir Auskunft gibt, daß hier ein Apache 2.4.7 auf Port 80 läuft. Leichte Panik. Embarassed
Auch nach einem erneuten Reboot - nix ... Rolling Eyes
Zum Glück gibt es das Internet und eine kleine Recherche bringt auf askubuntu.com des Rätsels Lösung:
Das Verzeichnis für den Webserver ist nicht mehr
/var/www
sondern neu
/var/www/html
!
Also die Webpage ins neue Verzeichnis kopiert und Drink alles wieder so, wie es sein soll!

Jetzt geht's an die Installation von OwnCloud. Very Happy
Thumbup


Desktop: Unity Gnome 3.X and LXDE Lubuntu

Version: 14.04 and 16.04

Hardware: Notebook and Server

Architektur: 32Bit and 64Bit

_________________
HW I: Lenovo ThinkPad X220, i7-2640M, 8GB RAM, 512GB SSD, 12,5" MATT, Ubuntu 14.04.X
HW II: HP Elitebook 2560p, i5-2520M, 8GB RAM, 500GB SSD, 12,5" MATT, Ubuntu 16.04.x (Mainline-Kernel)
HW III: Dell Latitude E4200, U9600, 3GB, 64GB SSD, 12" MATT, Apricity OS 64 Bit
Auch auf http://www.android-austria.info
OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenE-Mail sendenWebsite dieses Benutzers besuchenYahoo MessengerMSN MessengerSkype NameICQ-Nummer    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050160436 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.0791s (PHP: 80% - SQL: 20%) | SQL queries: 30 | GZIP enabled | Debug off ]