Ubuntu-Austria Foren-Übersicht
Portal  •  Forum  •  Profil  •  Suchen   •  Registrieren  •  Einloggen, um private Nachrichten zu lesen  •  Login   

 VirtualBox Update

Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Gast











BeitragVerfasst am: 21.02.2017, 21:21    VirtualBox Update Antworten mit ZitatNach oben

Update wurde vom SofwareCenter durch geführt nun startet VirtualBox mit USB 2.0 nicht mehr.

Wollte die VirtualBox Updaten kommt folgenden Fehlermeldung.

Das Zusatzpaket /home/daham/Downloads/Oracle_VM_VirtualBox_Extension_Pack-5.1.14-112924.vbox-extpack konnte nicht installiert werden.

VBoxExtPackRegister returned VERR_VERSION_MISMATCH, pReg=0000000000000000 ErrInfo='VirtualBox version mismatch - expected 5.1 got 5.0'.

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:ExtPackManagerWrap
Interface:IExtPackManager {edba9d10-45d8-b440-1712-46ac0c9bc4c5}


Was habe ich falsch gemacht oder


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 22.02.2017, 00:00    (Kein Titel) Antworten mit ZitatNach oben

VirtualBox ist neu,
aber dein Extension ist uralt.
Deinstallieren und das passende installieren
https://www.virtualbox.org/wiki/Download_Old_Builds
http://www.htpcbeginner.com/install-virtualbox-extension-pack-on-linux-windows/

Wenn es über die graphische Oberfläche nicht geht.
http://www.itzgeek.com/how-tos/mini-howtos/how-to-install-virtualbox-extension.html


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 22.02.2017, 12:18    (Kein Titel) Antworten mit ZitatNach oben

Die Version von VritualBox und der VirtualBox-Extension müssen immer die selben sein, ansonsten handelst du dir nur Probleme ein.

Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 22.02.2017, 16:39    (Kein Titel) Antworten mit ZitatNach oben

...auf diesen Link gehen:
https://www.virtualbox.org/wiki/Downloads
dort das VirtualBox 5.1.14 Oracle VM VirtualBox Extension Pack downloaden...
direkter Link: http://download.virtualbox.org/virtualbox/5.1.14/Oracle_VM_VirtualBox_Extension_Pack-5.1.14-112924.vbox-extpack

VBox starten und unter
>Datei >Einstellungen >Zusatzpakete installieren...
Zu jeden Update gibt auch ein neues Extension Pack!

PS: ...sollte eigentlich beim starten der VBox (nach Update) zum downloaden angeboten werden..


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 22.02.2017, 21:04    (Kein Titel) Antworten mit ZitatNach oben

So jetzt habe Virtualbox mit dem Software Center deinstalliert und wieder installiert in der Hoffnung das nun die neue Version oben ist.
Leider nun steht wenn ich mit USB 2.0 starte folgendes.

Für die virtuelle Maschine Windows 7 konnte keine neue Sitzung eröffnet werden.

The device helper structure version has changed.

If you have upgraded VirtualBox recently, please make sure you have terminated all VMs and upgraded any extension packs. If this error persists, try re-installing VirtualBox. (VERR_PDM_DEVHLPR3_VERSION_MISMATCH).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:ConsoleWrap
Interface:IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Wie oder was muss ich tun um die neue Version von VirtualBox zu installieren?

Grüße Gilli


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 22.02.2017, 22:58    (Kein Titel) Antworten mit ZitatNach oben

Was hast du gemacht? Bildlich übertragen:
Du hast ein Auto mit Autoradio. Es ist ein altes Auto und ein altes Autoradio. Ein Autoradio beim dem die Kabel blank gemacht werden und hinten eingeklemmt werden.

Dann kaufst du ein neues Auto, bei diesem gibt es für das Autoradio schon Stecker für die Kontakte. Du stellst fest Autoradio geht nicht. Also Auto verschrotten und genau das selbe noch mal kaufen.

Wieder das selbe Problem.

Besser Autoradio tauschen.
######################
« Butterfly » hat folgendes geschrieben:
VBox starten und unter
>Datei >Einstellungen >Zusatzpakete installieren...
Zu jeden Update gibt auch ein neues Extension Pack!

http://www.htpcbeginner.com/install-virtualbox-extension-pack-on-linux-windows/

Es gibt dort auch einen anderes Icon das Deinstalliert das Exension Pack.

Wenn es über die graphische Oberfläche nicht geht.
http://www.itzgeek.com/how-tos/mini-howtos/how-to-install-virtualbox-extension.html

#########
#########
jetzt hast du altes Autoradio weggeschmissen. Super.
Neues Autoradio holen, Achten aber auf Baujahr vom Auto.

Version kannst du über
VBox starten und unter
Hilfe -> über Virtual Box
dir herauslesen

Sollte das Extension Pack sein auf das Butterfly hin verlinkt hat.

###

Bin etwas gereizt, weil ich Nachhilfe geben habe und x-Mal auf unterschiedliche Arten dasselbe erklärt habe.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 23.02.2017, 11:13    (Kein Titel) Antworten mit ZitatNach oben

Hmmmm...
Erst mal, wäre sehr hilfreich, wenn du deine aktuelle Ubuntu-Version in deinem Profil eintragen würdest!

Also die VBox aus dem Softwarecenter ist die Version 5.0.32-dfsg-0ubuntu1.16.04.2, kann also mit dem von mir verlinkten Extesions-Pack nicht funktionieren Wink
In diesen, für mich unbrauchbaren Softwarecenter wird dir auch nicht das passende Extensions-Pack angeboten, ist aber in den Paketquellen..
Installieren im Terminal mit:
sudo apt install virtualbox-ext-pack


Besser ist es die Installation über die Dateien von virtualbox.org zu machen:
Hier mal die passende VBox downloaden, ist auch eine viel aktuellere Version:
https://www.virtualbox.org/wiki/Linux_Downloads
mit
sudo dpkg -i virtualbox-5.1_5.1.14-112924-Ubuntu-xenial_amd64.deb

installieren (muss natürlich die passenden für deine Ubuntuversion sein!!!)
Extensions-Pack von obigen Link downloaden und wie beschrieben installieren...
Done Smile


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 23.02.2017, 17:34    (Kein Titel) Antworten mit ZitatNach oben

Hallo

nun habe ich es so gemacht wie es von Webbutterfly beschrieben wurde.
Die Virtualbox im Software Center habe ich vorher deinstalliert.
Aber deinstalliert mittels des Software Center.


Danach Virtualbox im Terminal installiert.
Unter Virtualbox Datei/Einstellungen/Zusatzpaket installiert.
Nun kommt aber die Meldung.



Für die virtuelle Maschine Windows 7 konnte keine neue Sitzung eröffnet werden.

The virtual machine 'Windows 7' has terminated unexpectedly during startup with exit code 1 (0x1).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:MachineWrap
Interface:IMachine {b2547866-a0a1-4391-8b86-6952d82efaa0}

Liegt das daran das es eine vorhandenes System benutzt?

Was stimmt an meiner Ubunut Version im Profil nicht?
Bei meinem Rechner steht Ubuntu 16.04 LTS

Grüße Gilli Question


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 23.02.2017, 18:13    (Kein Titel) Antworten mit ZitatNach oben

Zitat:
Für die virtuelle Maschine Windows 7 konnte keine neue Sitzung eröffnet werden.

Hast Du im BIOS des PC die Virtualisierung aktiviert?

Gruß

Tom


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Webbutterfly
Administrator



Geschlecht:
Alter: 63
Anmeldungsdatum: 24.06.2006
Beiträge: 6917
Wohnort: Wien 23


austria.gif

BeitragVerfasst am: 23.02.2017, 18:45    (Kein Titel) Antworten mit ZitatNach oben

Zitat:
Hast Du im BIOS des PC die Virtualisierung aktiviert?

Thumbup
oder, es kann jetzt nur noch an dem installierten virtuellen System oder den Einstellungen dazu liegen...

Ich habe über Jahre hinweg immer meine virtuellen Systeme am laufen, ohne Probleme.
W7 hab ich sogar schon einige male geklont und die virtuelle Partition vergrößert...

Nachtrag 18:10
Im PDF Rolling Eyes steht ja was du machen sollst, führe
sudo /sbin/vboxconfig

aus

Bist du Mitglied der Gruppe vboxusers ?
kannst du feststellen mit
id

wenn nicht, dann
sudo usermod -aG vboxusers BENUTZERNAME


PS: Mit Win gibts auch bei mir immer wieder Probleme in der VBox, meistens zu wenig Speicher oder Platz... nervt Wink

PS: Du kannst einen Screenshot einfach an dein Posting anhängen, sollte nicht breiter als 800px sein!
Ein PDF ist nicht wirklich das wahre Wink


Desktop: Gnome-Shell 3.X

Version: 14.04 and 16.04

Hardware: Notebook

Architektur: 64Bit

_________________

European Open Source Center
www.webbutterfly.com

OfflineBenutzer-Profile anzeigenPrivate Nachricht sendenWebsite dieses Benutzers besuchen    
Gast











BeitragVerfasst am: 24.02.2017, 12:23    (Kein Titel) Antworten mit ZitatNach oben

Hallo,

wenn ich kurz was anmerken dürfte ...
bestehnedes Image vom VM-Windows-Guest sichern.
a) würde ich mal Virtualbox aus den Standard-Paketquellen deinstallieren
b) vielleicht mal im Terminal: sudo apt-get autoremove durch-/ausführen,
c) danach sudo apt-get dist-upgrade
d) danach für VirtalBox aktuelle Paketquelle hinzufügen (siehe Anleitungen)
https://wiki.ubuntuusers.de/VirtualBox/Installation/
https://www.virtualbox.org/wiki/Linux_Downloads

und über Terminal installieren und Deinen User checken ob er in der Gruppe ist (siehe Posting von Webbutterfly ober mir)

danach ExtensionPack ... (aber danach sollte VirtualBox eh beim starten automatisch fragen) ...

Und dann das bestehende VM Image in Virtualbox öffnen.

auf die Gasterweiterung nicht vergessen.

« TomTobin » hat folgendes geschrieben:
Zitat:
Für die virtuelle Maschine Windows 7 konnte keine neue Sitzung eröffnet werden.

Hast Du im BIOS des PC die Virtualisierung aktiviert?
Gruß
Tom


Meinst du damit SecureBoot deaktiviert (bei Uefi)???


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 24.02.2017, 12:37    (Kein Titel) Antworten mit ZitatNach oben

Zitat:
Meinst du damit SecureBoot deaktiviert (bei Uefi)???

Nein, ich meine die Virtualisierungstechnik im BIOS bzw. EFI. Die Einstellung wird unterschiedlich benannt z.B. VT-x oder Virtualisierungs- technik -modus oder Vanderpool-Option oder oder...

Insbesondere bei 64Bit Systemen muss diese Einstellung am Host (also dem PC) bei VBox aktiviert sein. Ob VT-x auch innerhalb der VBox für den Gast aktiviert werden muss hängt vom Gast-OS ab.

Gruß

Tom

Edit: Wenn Secureboot aktiv wäre, dürfte sich VBox gar nicht installieren lassen.


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 24.02.2017, 12:44    (Kein Titel) Antworten mit ZitatNach oben

« TomTobin » hat folgendes geschrieben:
Zitat:
Meinst du damit SecureBoot deaktiviert (bei Uefi)???

Nein, ich meine die Virtualisierungstechnik im BIOS bzw. EFI. Die Einstellung wird unterschiedlich benannt z.B. VT-x oder Virtualisierungs- technik -modus oder Vanderpool-Option oder oder...

Insbesondere bei 64Bit Systemen muss diese Einstellung bei VBox aktiviert sein.

Gruß

Tom

Edit: Wenn Secureboot aktiv wäre, dürfte sich VBox gar nicht installieren lassen.


Wie gut, dass mein Rechner offenbar so alt ist, dass eine solche Einstellung nicht vorhanden ist im BIOS ... (oder jene war bei mir von Anfang an VBox Freundlich eingestellt ... ) ... wäre mir im Bios auch noch nie aufgefallen ... (hab auch nie aktiv danach gesucht muss ich zugestehen)

aber danke für die Info ... man lernt nie aus ...

so wie ich den User verstanden habe, hat Vbox ja schon mal funktioniert ... nur offenbar hat sich bei dem Update was zerschossen was dann die Probleme verursacht.

lg


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Gast











BeitragVerfasst am: 24.02.2017, 13:04    (Kein Titel) Antworten mit ZitatNach oben

OT:
« Beginner » hat folgendes geschrieben:

Wie gut, dass mein Rechner offenbar so alt ist, dass eine solche Einstellung nicht vorhanden ist im BIOS ...

Hüte ihn wie deinen Augapfel Wink
Ich hab hier einen, da ist Secureboot deaktiviert - jedenfalls laut Einstellungen - interessiert den Rechner allerdings nicht Rolling Eyes

Witzig ist: Ich kann EIN beliebiges OS installieren - kein Problem, sobald ich aber ein Dualboot möchte geht der Ärger los. Na ja, im Legacy-Modus funktioniert alles. Aber bis man da drauf kommt... Evil or Very Mad


Desktop: anderer

Version: 16.04

Hardware: Notebook

Architektur: 64Bit
Online    
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Berechtigungen anzeigen


Forensicherheit

1008050171579 Angriffe abgewehrt

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
Alle Zeiten sind GMT + 2 Stunden



[ Page generation time: 0.3143s (PHP: 53% - SQL: 47%) | SQL queries: 90 | GZIP enabled | Debug off ]